Support » Plugin: Wordfence Security - Firewall & Malware Scan » Web Application Firewall is disabled

  • Resolved elaine.wildash

    (@elainewildash)


    Just received an alert message from a site using Wordfence saying:

    Wordfence’s Web Application Firewall has been unexpectedly disabled. If you see a notice at the top of the Wordfence admin pages that says “The Wordfence Web Application Firewall cannot run,” click the link in that message to rebuild the configuration. If this does not work, you may need to fix file permissions. More Details

    However on checking the firewall is Enabled and Protecting, there is no notice and the file permissions look OK.

    Can you advise?

    Thanks.

Viewing 1 replies (of 1 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @elainewildash,

    Can you check these two places?

    1. Run SELECT val FROM wp_wfconfig WHERE name = 'waf_status'; on your database.

    This should return enabled.

    2. Edit the file /wp-content/wflogs/config.php.

    You should be able to find s:9:"wafStatus";s:7:"enabled" somewhere in the file.

    If either one of them isn’t what it should be, can you follow these steps?

    1. Delete the /wp-content/wflogs/ folder
    2. Remove the auto_prepend_file = *** within your .htaccess or .user.ini
    3. Try to re-enable the Web Application Firewall again

    Dave

Viewing 1 replies (of 1 total)
  • The topic ‘Web Application Firewall is disabled’ is closed to new replies.