Support » Plugin: Inline Google Spreadsheet Viewer » Web App script not displaying results

  • Resolved ksumwalt

    (@ksumwalt)


    My apologies if this has been answered in a previous thread. I could not find one and I believe I followed the documentation correctly.

    I have tried a couple web app scripts and am not getting them to work. All that I have tried are published so that Anyone, Even Anonymous can access and are run as me since they end up accessing spreadsheet or other files which do not have public access. These have been run successfully by others outside of the WordPress site, using the link I am trying to use on my WordPress page. I have also used an iFrame plugin on the same page and had the script display correctly using that.

    I have successfully shown spreadsheet data using the plug-in so I know it is working.

    The web app link example below is one I am trying to display inside a page. It creates an HTML page to present the information in a spreadsheet. I have tried inserting the following, but it does not result in any output:
    [gdoc key=”https://script.google.com/macros/s/AKfycbwppK-KcJLJZiDVOutTylGaqZkj-gQGxgKecDpVfPGXThs-A1s/exec”]

    By deleting the url between the quotes and inserting one to a spreadsheet, I get the spreadsheet view, so I believe this is an issue with either the content of the script, the method I am using to access the script, or otherwise. Any suggestions on getting these web apps to work?

    Note that my code for the above linked sample begins by running this:

    function doGet(passed) {
    
      if(passed.parameter.festival && passed.parameter.year){
        Logger.log(passed.parameter);
        passedParameter = passed.parameter.festival + ' ' + passed.parameter.year;
      }
    
      var result=HtmlService.createTemplateFromFile('list').evaluate()
            .setTitle('Boxwood Festival Class Schedule')
            .setWidth(1285)
            .setXFrameOptionsMode(HtmlService.XFrameOptionsMode.ALLOWALL);
    
      return result;
    
    }
    • This topic was modified 2 months ago by  ksumwalt.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Meitar

    (@meitar)

    Your GAS Web App should output an HTML fragment, as described in the readme. You are using the HtmlService, which if I remember correctly produces a complete HTML page. As you know, you cannot insert an HTML page into the middle of another HTML page directly.

    ksumwalt

    (@ksumwalt)

    Thank you for the reply. My apologies. With my limited self taught knowledge I did not properly understand the use of the term fragment in the documentation and ended up glancing past it as a result. Now to see how I can make that happen, if at all possible with these scripts.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.