Support » Plugin: CTX Feed - WooCommerce Product Feed Generator » wc_post_id_ missing

  • Resolved Chiotas

    (@chiotas)


    Hello,
    Not sure who is reading this forum so first of all thanks for creating CTX that is the best way found to feed my IG shop.

    I have a question as I’m getting a sync issue: before CTX (so using only Facebook for Woocommerce), every product uploaded got a “wc_post_id_” suffix for the “Content ID” just before the SKU.
    After installing CTX, for some products (not all of them), the Content ID on the IG is without “wc_post_id_” and so I get the error “Events With Unmatched Content IDs”

    How can I fix this?
    Is it correct to use both CTX and Facebook for Woocommerce plugins?

    Here a screenshot of what I get for an “ok” product and for one with issues: LINK

    Thanks for the support

    • This topic was modified 2 months, 2 weeks ago by Chiotas.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ohidul Islam

    (@wahid0003)

    Hi @chiotas

    To fix the issue you need to add “wc_post_id_” as a prefix for the product id attribute into feed configuration. See this screenshot: https://www.dropbox.com/s/hncdcx3unnyo31u/2021-09-19_16-56-05.png?dl=0

    As you configured Facebook pixel with Facebook for WooCommerce plugin so you need to keep the plugin on your site.

    Thread Starter Chiotas

    (@chiotas)

    Thank you! I’ll try immediately

    Thread Starter Chiotas

    (@chiotas)

    Hello again.
    The fix worked in terms of errors on Facebook Business platform, but now my catalog is messed up.

    Here a screenshot with an example: LINK

    So basically now “wc_post_id_” feeds correctly, but I lose the variation family (every product is 1 parent 4 child).
    For the products that are still ok, I don’t get anymore wc_post_id_ for content ID but I get apparently a mix between SKU (FGxxx) and a number I don’t recognize (it’s apparently a mix between variant number and product id). Example FG6643-02_5202 is SKU (FG6643) Variant (01) Product ID (5202)
    Any idea how to have back the product tree?
    Thanks

    Plugin Contributor Mrinal Haque

    (@mrinal013)

    Hello @chiotas

    Thank you for your reply.

    Please go to CTX Feed > Status, click on the Copy Status and send us the status here. Also, mention which feed you used for the Facebook catalog.

    Plugin Author Ohidul Islam

    (@wahid0003)

    Hi @chiotas

    Sorry, it was my fault. You need to set the prefix for both Product Id and Item group id attribute. Follow this screenshot: https://www.dropbox.com/s/egx7mkmli2aazvk/2021-09-20_11-30-01.png?dl=0

    Thread Starter Chiotas

    (@chiotas)

    Brilliant, it worked perfectly! Thank you!
    I still get two different Content IDs (wc_post_id_xxxx and FGxxxx-yy_zzzz) but I suppose it’s not a big issue

    • This reply was modified 2 months, 2 weeks ago by Chiotas.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.