Support » Plugin: Sliced Invoices - WordPress Invoice Plugin » wc_deposit_meta: Array

  • Resolved Joseph G.

    (@illumination2025)


    Hi there!

    First and foremost, thank you for providing the open source community with your wonderful plugin.  Great job.  

    Next: 

    We are seeing the following on Invoice and Quote pages:  wc_deposit_meta: Array
    (see screenshot)

    Should this not show the product details (which is what we are hoping)?

    Thanks!  If you need anything from me, please feel free.

    -joseph

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author SlicedInvoices

    (@slicedinvoices)

    Hi Joseph,

    Thanks for the kind words, I really appreciate it.

    Regarding your issue, I don’t see any screenshot here. Can you please try again to send it?

    Thanks,
    David

    Joseph G.

    (@illumination2025)

    Here you go:

    https://verilucis.com/img/david-slice.png

    Thanks, David!!!

    Plugin Author SlicedInvoices

    (@slicedinvoices)

    Hi Joseph,

    Thanks for your patience. I see the screenshot now. You must be using our Woo Invoices plugin, and the wc_deposit_meta must be a WooCommerce item meta. If you want to get rid of that your options are:

    1) Turn off metas from being displayed altogether. You can do this by unchecking the setting under WooCommerce / Settings / Sliced Invoices / “Show meta fields on line items”.

    2) Filter out just the wc_deposit_meta meta specifically. We have a filter for this kind of thing called ‘sliced_woocommerce_order_item_metas’. There’s an example of how to use it here:

    https://gist.github.com/grantalltodavid/27722e585c90c7a607e01189f3451f14

    This example filters out a meta called ‘_gravity_forms_history’, but in your case just change that to ‘wc_deposit_meta’ and you’ll be good to go.

    Hope that helps! If any of the above doesn’t make sense, or if I didn’t understand your question correctly, just let me know.

    -David

    hi
    I don’t see sliced invoices under woocommerce-settings?

    Joseph G.

    (@illumination2025)

    Yes, so David, the UI has changed… I did take your filter and nulled it out, as it wasn’t working otherwise… at the end of the day, I also had to rework the form and some queries anyway.

    I appreciate your help anyway, and your demeanor! 🙂

    Might consider checking out the most recent UI for Wooo… the first list item above cannot be found in backend.

    Thanks, and can close this ticket (Or leave it open) whenever you wish.

    Thanks again for all of your hard work and helping out! I imagine it can be pretty hectic to keep up with everything! 🙂

    Sincerely,

    Joseph
    verilucis.com

    Joseph G.

    (@illumination2025)

    Ps. Sorry I didn’t get back sooner! 🙂

    Plugin Author SlicedInvoices

    (@slicedinvoices)

    I omitted to say it’s under the “Payments” tab. So to be more accurate I should have said the setting is here: WooCommerce / Settings / Payments / Sliced Invoices / “Show meta fields on line items”.

    Screenshot: https://imgur.com/De0GoX0

    Cheers,
    David

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘wc_deposit_meta: Array’ is closed to new replies.