Support » Plugin: Contact Form 7 Honeypot » WC3 Validation Error

  • Resolved reachdigital

    (@reachdigital)


    Hi Recently we have noticed we are getting a bad value see below.

    I am not sure if its to do with this change in 1.11 :

    “Addresses accessibility concerns regarding a missing label and disables autocomplete to prevent browser autocomplete functions from filling in the field. ”

    Error:

    Error: Bad value nope for attribute autocomplete on element input: The string nope is not a valid autofill field name.
    From line 274, column 185; to line 274, column 317
    y.</label><input class=”wpcf7-form-control wpcf7-text” type=”text” name=”honeypot-252″ value=”” size=”40″ tabindex=”-1″ autocomplete=”nope” /></span

    I have tested older version and seem to validate OK so I believe the latest update is causing the error.

    I hope you can fix this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ryan

    (@daobydesign)

    Hi. The validation error is an artifact of what I feel is an important update to how the plugin handles browser form autocompletion.

    There is more information here, as well as instructions on how to force compliance (with slightly reduced plugin functionality).

    Thank you for the resposne and update . I ran the new update 1.12 and click on verify and said all is OK however I am still seeing the error. How do I go about editing a past generated tag?

    Plugin Author Ryan

    (@daobydesign)

    Edit the contact form that has the honeypot tag in it, and then either generate a new tag using the tag generator, or simply add validautocomplete:true just before the closing ‘]’ in your current tag. So it ends up looking something like:

    [honeypot honeypot-555 id:someID class:someClass validautocomplete:true]

    Thank you Ryan,

    “Simply add validautocomplete:true ” worked a treat.

    Cheers!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.