Support » Plugin: WC-AC Hook » WC Tag & Contact Not Feeing into AC

  • Resolved jamestsa

    (@jamestsa)


    Hi. Firstly, thank you for the awesome plugin. It is great.

    I am really struggling to understand why the integration isn’t happening properly between WC & AC. Here’s what I’ve done thus far:

    – Set the plugin to integrate inclusive of AC URL and API Key.
    – Added a tag (bbi) in the ‘ActiveCampaign Tag’ field within the product’s ‘Advanced Settings’
    – Selected the field ‘Add/Update Contact’
    – UNselected ‘Track Order Status’
    – The field ‘Default Tag’ (in Integration tab of WC settings) is ‘Purchased’

    – However, when an order is placed, it doesn’t create a new contact in AC, and thus, it doesn’t add in my tag or doesn’t trigger the automation.

    – Within AC, I have created a form and set it so that the tag (bbi) will be added each time the form is ‘triggered’. AC Support advised automation is setup correctly.

    ==> So, it seems I need the WooCommerce contact AND tag to feed across correctly when an order is placed for the automation to then begin.

    Would be grateful for any questions, thoughts or suggestions you have on how I could resolve this.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mtreherne

    (@mtreherne)

    Hi there,

    The first thing to do is to check the debug log. To do this you must enable debug logging.

    1. Login as a WordPress admin or shop manager
    2. Select the menu ‘WooCommerce > Settings > Integration > WC-AC Hook’
    3. Ensure that the ‘Debug Log’ option is checked to enable logging

    You can view the debug log at ‘WooCommerce > System Status > Logs > wc-ac-hook-*’. Select the log and click on view. If you switch on debug logging then you will need to wait for you next shop order before you see an entry in the log.

    The debug log will confirm that your AC URL and API Key are working, and will also show you successful (or not) sync of contact data.

    With the settings you have the contact and tags should be created when the order changes status to ‘processing’ i.e. when payment is made.

    The form on ActiveCampaign is not required for this integration to work.

    Get back to me with the last message from the debug log and we’ll take it from there.

    Hello. Thank you for your response. I forwarded your message to my IT guy and he has been able to resolve the issue – so WC & AC are now talking to each other as they should be – and the ‘tag’ in AC is working and triggering the automation.

    Aggh, life is great when things work out as they should.

    Appreciate your support,
    James.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WC Tag & Contact Not Feeing into AC’ is closed to new replies.