Support » Plugin: WooCommerce Services » WC Shipping error

  • Resolved donescobar

    (@donescobar)


    I’m having trouble getting shipping rates to pull up on the front end, enabling logs resulted in the following but searching for this issue hasn’t returned anything. Anyone got any ideas what this means?

    04-21-2018 @ 17:19:13 - Service settings empty. Skipping wc_services_usps rate request (instance id 6). (calculate_shipping)

    any help would be awesome! thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Also, currently using the following

    WooCommerce 3.3.5
    Jetpack 6.0
    Wordpress 4.9.5

    Plugin Contributor Paul Dechov

    (@pauldechov)

    Hi donescobar,

    A few questions to try and get to the bottom of this issue. On that status page, are you seeing “No service data available” under Health » WooCommerce Services Data? If so, does clicking “Refresh” to manually load the service data make a difference?

    Also, have you configured the settings for this shipping method in WooCommerce » Settings » Shipping » [zone] » USPS?

    Regards,

    Paul

    Hello Paul,

    Thank you for your reply, so when I go to WooCommerce Services and look under Health I get 3 green checkmarks stating everything runs ok.

    The only error I get occasionally is the block of info under Health, titled Services and it displays an error saying “The most recent rate request failed” for USPS. I have followed videos online showing me how to set up shipping zone which I’m fairly confident is set up correctly and turned on logging so I can see what’s happening and I get the error message I posted above in my first post.

    Thanks

    as a side note, I’d like to add that even when it displays a green checkmark for retrieving the USPS rates I get the following in the front-end when trying to get a quote

    No rates found, adding fallback. (USPS:6)

    Plugin Contributor Paul Dechov

    (@pauldechov)

    Hi donescobar,

    I’d like to try and reproduce this issue to see what the cause might be. A few pieces of information may help:

    – What is your origin ZIP?
    – Which USPS shipping services have you enabled?
    – Are you seeing the same issue no matter what is in your cart? What are the weights and dimensions of the items in your cart?

    Thanks,

    Paul

    Unbelievable enough as I am gathering all the details and without doing anything further on my part, it started pushing out prices from USPS.

    I will do some further testing, but as we stand it seems to be working well now.

    Thank you very much for your time Paul!

    donescobar

    Plugin Contributor Paul Dechov

    (@pauldechov)

    Great to hear – let us know if you run into any more trouble!

    Paul

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WC Shipping error’ is closed to new replies.