Support » Plugin: WooCommerce » WC Query / price_filter error after updating

  • mncd

    (@mncd)


    I was asked to do some updates on a website. I did not build it and I know little about the details of its structure.

    I updated WordPress from 4.3x to 4.6 and also updated a number of plugins.

    It turns out that the theme being used, “Blvck”, has been discontinued entirely. I believe this is where the error is coming from. When on the shop pages (the site uses WooCommerce) I get the error below…


    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘WC_Query’ does not have a method ‘price_filter’ in /home/victoria/public_html/wp-includes/plugin.php on line 235

    Warning: array_unique() expects parameter 1 to be array, null given in /home/victoria/public_html/wp-content/plugins/woocommerce/includes/class-wc-query.php on line 395

    When I search for these specific errors (including line numbers) I found many other sites which are throwing the same exact error. On one theme support forum (not my theme nor theme creator) I found a thread where the developer had identified and fixed the problem.

    Since my theme is discontinued and apparently unsupported, I need to figure out how to fix it myself. I’d rather not switch themes because I’m afraid it could turn into a massive job to rebuild the site. Note that after the wordpress and woocommerce updates, woocommerce said some of the theme’s woocommerce template files were outdated. I have since copied over the latest woocommerce files and that did not fix the error.

    Any suggestions of what I can do now?

    The problem pages are here… at the link below and any product page offshoot.

    http://www.victoriasix.com/collections/

    Note this problem doesn’t seem unique… I found a number of other sites with this same error — just google: wc_query line 235

    System status below…

    ### WordPress Environment ###
    
    Home URL: http://www.victoriasix.com
    Site URL: http://www.victoriasix.com
    WC Version: 2.6.4
    Log Directory Writable: ✔
    WP Version: 4.6
    WP Multisite: –
    WP Memory Limit: ❌ 40 MB - We recommend setting memory to at least 64MB. See: Increasing memory allocated to PHP
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: ❌ 5.4.22 - We recommend a minimum PHP version of 5.6. See: How to update your PHP version
    PHP Post Max Size: 25 MB
    PHP Time Limit: 30
    PHP Max Input Vars: 990
    cURL Version: 7.24.0
    OpenSSL/1.0.0
    
    SUHOSIN Installed: –
    MySQL Version: ❌ 5.5.50 - We recommend a minimum MySQL version of 5.6. See: WordPress Requirements
    Max Upload Size: 25 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 2.6.4
    :
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔
    
    ### Active Plugins (14) ###
    
    All In One SEO Pack: by Michael Torbert – 2.3.9.1
    Contact Form 7: by Takayuki Miyoshi – 4.5
    WC Facebook Comment & Share: by Shameem Reza – 1.5.3
    WooCommerce Quickview: by James Kemp – 3.0.7
    WPBakery Visual Composer: by Michael M - WPBakery.com – 4.4.3
    MailChimp for WordPress Lite: by ibericode – 2.3.12
    Pluton Custom Post: by pluton – 1.0.0
    Pluton shortcodes: by pluton – 1.0.0
    Regenerate Thumbnails: by Alex Mills (Viper007Bond) – 2.2.6
    Revolution Slider: by ThemePunch – 4.6.5
    UpdraftPlus - Backup/Restore: by UpdraftPlus.Com
    DavidAnderson – 1.12.17
    
    WooCommerce Social Buttons: by Vivacity Infotech Pvt. Ltd. – 1.0.3
    WooCommerce: by WooThemes – 2.6.4
    WordPress Importer: by wordpressdotorg – 0.6.3
    
    ### Settings ###
    
    Force SSL: –
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    
    ### API ###
    
    API Enabled: ✔
    
    ### WC Pages ###
    
    Shop Base: #666 - /collections/
    Cart: #12 - /cart/
    Checkout: #13 - /checkout/
    My Account: #14 - /my-account/
    
    ### Taxonomies ###
    
    Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    ### Theme ###
    
    Name: Blvck
    Version: 1.2.2
    Author URL: http://nrgthemes.com
    Child Theme: ❌ – If you're modifying WooCommerce on a parent theme you didn't build personally
    then we recommend using a child theme. See: How to create a child theme
    
    WooCommerce Support: ✔
    
    ### Templates ###
    
    Overrides: blvck_v1.2.2/woocommerce/archive-product.php
    blvck_v1.2.2/woocommerce/cart/cart-shipping.php
    blvck_v1.2.2/woocommerce/cart/cart-totals.php
    blvck_v1.2.2/woocommerce/cart/cart.php
    blvck_v1.2.2/woocommerce/checkout/form-billing.php
    blvck_v1.2.2/woocommerce/checkout/form-checkout.php
    blvck_v1.2.2/woocommerce/checkout/form-shipping.php
    blvck_v1.2.2/woocommerce/content-product.php
    blvck_v1.2.2/woocommerce/content-single-product.php
    blvck_v1.2.2/woocommerce/global/wrapper-start.php
    blvck_v1.2.2/woocommerce/loop/orderby.php
    blvck_v1.2.2/woocommerce/loop/pagination.php
    blvck_v1.2.2/woocommerce/myaccount/form-login.php
    blvck_v1.2.2/woocommerce/myaccount/my-address.php
    blvck_v1.2.2/woocommerce/order/order-details.php
    blvck_v1.2.2/woocommerce/single-product/product-image.php
    blvck_v1.2.2/woocommerce/single-product/related.php
    blvck_v1.2.2/woocommerce/single-product/short-description.php
    blvck_v1.2.2/woocommerce/single-product.php

    https://wordpress.org/plugins/woocommerce/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Try disabling the template overrides and see if that resolves the problem. You can do that at WooCommerce > System Status > Tools.

    Otherwise, you’re probably going to need to hire a developer to take a look. Long term though, it would make sense to switch themes. I’d recommend checking out storefront: https://woocommerce.com/storefront/

    mleidlein

    (@mleidlein)

    Upgraded last night. I have the same issue. Used a theme called Room09. I do not see an option to disable template overrides under the Tools tab so I don’t see how this can help.

    Hello @mleidlein I am also using Room09 and have the same error like you are having after updating WordPress and Woocomerce. Did you solved the problem already? If so I hope you can help me.
    Thanks!

    Hi Guys,

    Same problem here on the same Theme Room09 🙁
    Looking for a fix as well. I will post here if anything.

    Any progress on your end? did you fix the error?
    Cheers

    Hi there , is there anyone who has solved this problem?

    User MNCD : your site is working again….please info us

    Same here with Room09
    What’s going on?

    Solution for me ( and possible solution for more ):

    Made a total backup with https://nl.wordpress.org/plugins/backup/ and after that restored the backup and the problem was solved.

    Hello everyone,
    i face also this problem, and i am tired to solve this, but i can not solve this problem. Can you solve this?
    Please anyone help me to solve this problem.

    Hi,
    If I am not mistaken the latest Room09 update takes care of this issue. Did it for me.
    😉

    I’m sorry I never followed up with this thread. I missed the notifications about it.

    Unfortunately, my absence is inconsequential because I don’t have much help to give. I did get the site working again, but I had to completely change the theme.

    The one that the previous designer had used, Blvck, was discontinued and the company completely dropped support and made no attempt to help. There’s no reason they should remain anonymous in fact. Avoid this company — NRGThemes — they were useless and did not support their product and it wasn’t even all that old. Completely nonresponsive, disreputable and unreliable company as far as I’m concerned. Stay away from them.

    • This reply was modified 2 years, 1 month ago by  mncd.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WC Query / price_filter error after updating’ is closed to new replies.