Support » Plugin: WooCommerce Products Per Page » WC 3.3.1 Not Working with the plugin

Viewing 6 replies - 16 through 21 (of 21 total)
  • Hi Jeroen and thank you for your reply
    I have now activated both plugins

    Regards

    Plugin Author Jeroen Sormani

    (@sormano)

    Thank you.

    So I see that it does properly reload the page as expected, and it does keep the value of the number of products per page in the dropdown.

    From what I can tell something else (possibly the filter plugin) is overriding the number of products per page shown. This could also potentially be your theme.
    When I tested the plugin it was refreshing the PPP through AJAX with the other plugin enabled, on your site that doesn’t appear to happen. Not sure if they may indicate something too..

    It appears you’re running a version 2.0.7.5 or something on your site of the plugin, while the current seems to be at 1.2.4 (https://wordpress.org/plugins/woocommerce-ajax-filters/)

    Regards,
    Jeroen

    HI
    Thank you for taking the time to look into this and reply
    I have found a better alternative
    The theme (Rehub revendor)dev has now added product filters to the themes own widgets
    So.. no more plugin needed for product filters 🙂
    I have deleted the old AAPF plugin and created new filters using the themes inbuilt widgets and your products per page now works great 🙂 🙂
    Thanks again for your support

    • This reply was modified 1 week, 3 days ago by  norfolkandway. Reason: added now working info

    Hello,

    I previously used custom code to control this (I want to display all products on the same page), but the WC update to 3.3.1 (I believe) cause it to stop working. It was essentially this code:

    —–
    add_filter( ‘loop_shop_per_page’, ‘new_loop_shop_per_page’, 20 );

    function new_loop_shop_per_page( $cols ) {
    // $cols contains the current number of products per page based on the value stored on Options -> Reading
    // Return the number of products you wanna show per page.
    $cols = 100;
    return $cols;
    }
    —–

    In searching for a solution, I found your plugin. I love its simplicity, but it is unfortunately not working for me either. You can see this on the product listing on my test site: https://test.virtualstrides.com/product-category/available-medals/

    (to see this site, use guest/vstrides)

    From reading through this thread, I am guessing this means there is a conflict somewhere. Are you able to help me identify where that might be coming from? Please keep in mind my site uses a LOT of plugins, including many custom written ones that are essential for the site to function. I guess I am hoping you see some obvious error that would point me in the right direction.

    Thanks,
    Mark

    • This reply was modified 3 days, 8 hours ago by  Rogue23.

    Hello again,

    As a side note to the post above, I did notice something strange: When I increase the number of Shop Columns, not only do that increase, but it adds more products to each page as well. It looks very strange, with gaps in the product listings from row to row, but the higher the number I select there, the more items show per page and the fewer pages there are.

    I have the list of dropdowns and default products per page set to -1, because I want everything to display (ideally in 4 columns).

    -Mark

    Plugin Author Jeroen Sormani

    (@sormano)

    Hi Mark,

    You can try to increase the priority of ’20’ on the custom code snippet you’ve used before (try a high number like 999).

    The conflict can come from anywhere, the best way to debug it is to start disabling plugins/theme and test things in between.

    The gaps with the columns are caused by your theme not being prepared for showing the set number of columns.

    Cheers
    Jeroen

Viewing 6 replies - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.