Support » Plugin: YITH WooCommerce Wishlist » WC 2.7.0 (Beta 2) issues

  • Hi,
    you might want to look at incoming WC 2.7.0, there’s been a lot of changes. I updated “add-to-wishlist.php” and “add-to-wishlist-button.php” templates, but it seems that your plugin has other places with soon deprecated function calls. See this notice:

    Notice: id was called incorrectly. Product properties should not be accessed directly.

    I solved this with version_compare, in templates:

    $product_id = ( version_compare( WOOCOMMERCE_VERSION,'2.7.0' ) >= 0 ) ? $product->get_id() : $product->id;

    But there are still errors from the plugin, which I can’t override with template files.
    Perhaps you might want to take a look at this (asap, of course 😉 ).

    Here’s the WC 2.7.0 Beta 2 link
    There are plenty more stuff to check, 2.7.0 update is a big one.

    Cheers

Viewing 1 replies (of 1 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi Anydog,

    of course we’re working to integrate all our plugin with WC 2.7 🙂

    We started integration process since WC 2.7-beta-1, and we’re still working to make everything compatible with new revision, and to maintain backward compatibility since WC 2.5.x

    Please, stay tuned for any future update 😉
    Have a nice day

Viewing 1 replies (of 1 total)
  • The topic ‘WC 2.7.0 (Beta 2) issues’ is closed to new replies.