Support » Plugins and Hacks » Wavr does not display anything

Wavr does not display anything

  • garyploski


    I installed Wavr and tried pasting the url of a wave, a wave id only, and the sample wave id presented in the FAQs but nothing displays.

    Here is the test page:

    This is the code I have presently using the sample wave id from the FAQs:
    [wave id=”googlewave.com!w+ig2e7T0UC” color=”#ffffff” bgcolor=”#000000″ font=”Arial, Helvetica, sans-serif”]

    Here it is with my wave
    [wave id=”googlewave.com!w+BrKwHWkEMW” color=”#ffffff” bgcolor=”#000000″ font=”Arial, Helvetica, sans-serif”]

    Am I missing something?


Viewing 15 replies - 1 through 15 (of 23 total)
  • lucascaro


    Hi! i can see the example wave in there. I guess you need to use yours or a wave you’re added to. Are you logged in to wave on the same browser? do you have the last version of wavr? (0.2.2)



    Yes, I am logged in to Wave on the same browser (FF 3.5.3).

    I have the latest version – 0.2.2.

    Using a different browser (Safari) I am prompted to login but I do not see anything – blank white space.



    I updated the code to be:

    [wave id="googlewave.com!w+BrKwHWkEMW" color="#ffffff" bgcolor="#000000" font="Arial, Helvetica, sans-serif"]

    I still see the same black background with no text.



    I do have the same problem. Not a single page I visited with embedded waves so far displayed it properly. On some pages I can see a google wave preview window but clicking into it brings me to my personal inbox, not the embedded wave.
    Neither could I get the wavr plugin to work on my blog. I tried the full ID as garyploski used it, I tried only the alphanumeric part of the ID, I also tried it with just the part after the exclamation mark. Only difference I noticed to other wave users so far is, that the wave IDs on my account contain “!w%” rather than “!w+”.
    Does anybody have an idea why this is not working? Do I have to make the public first?



    Make sure you make the wave public by adding public@a.gwave.com as a participant to your wave. Otherwise it will not be visible by anyone but you.



    @aigarius Thanks for the heads up.

    Hmm, searching for the account I was prompted with the following: public@a.gwave.com is not a Google Wave account.

    Here is the resolve to the issue noted above: http://lifehacker.com/5376138/google-wave-101

    I tried adding the user to my wave… Still no luck. My wave isn’t viewable by me or anyone else when embedded into my site/a blog using this plugin. =\



    @garyploski: Just click on the plus button beside the “Manage contacts” link. An “Add New Contacts” window will appear, and just type “public@a.gwave.com” in the field box. Even if it complains, just press Enter until it shows up in your contact list.


    Thanks for the suggestion. I tried adding public@a.gwave.com and received the following error:

    User does not have a Google Wave account.

    I think there have been many changes on the Wave servers and this is one of the casualties.

    Using the ‘search’ option in the contacts panel the result is:

    public@a.gwave.com is not a Google Wave account.

    I tried again, as things seem to work and then not work, repeat, in wave at random times.

    I ‘added’ public@a.gwave.com to my contacts list and tried adding it to the wave with no success.

    As you can see I tried this previously with the same result.

    when you get the message

    public@a.gwave.com is not a Google Wave account.

    just ignore it and hit Enter, it will be added to your contacts list and you can drag it to any wave you want. a yellow message appears that says:

    [not-yet-implemented-user] gave everyone access.

    the wave should be public.

    good luck.

    Remember that wave is in a preview and still have some bugs and not implemented features.

    Can you please try using any other public wave you find on your inbox?

    @bjeurope, the wave id should not have the %252 in it. That has to be replaced by a +

    Wavr’s latest version (0.2.2) will try to guess the id from the url, so please try updating and using the “wave” button in your editor, and paste the full url for your wave (make sure to have only that wave opened when you copy the url).

    thanks for the feedback!

    Could someone provide a test configuration that works so I/other people can test Wavr? Two samples might be best. One using the googlewave.com server and another using the wavesandbox.com server.

    I’ve tried with other public waves, created new public waves, and the original wave but nothing seems to work.

    Thanks for the support and continued development of Wavr.

    The following works for me with wavr 0.2.3 and wordpress 2.8.5:

    [wave id=”googlewave.com!w+NcOxJo8SW”]

    [wave id=”googlewave.com!w+NcOxJo8SW” server=”https://wave.google.com/wave/”]

    that is a public wave i just grabbed.

    Thanks to you for keeping on trying!

    Some good news…

    The ‘Public’ account is now appearing in my test wave.
    I added it to my contact list.
    There is now text stating “Everyone has access to this wave.”
    This [wave id="googlewave.com!w+NcOxJo8SW" server="https://wave.google.com/wave/"] worked when I put it into my post.

    The bad news…

    I switched out the wave id with my test wave and it did not load anything.

    Here is what I have:
    [wave id="googlewave.com!w+BrKwHWkEMW" server="https://wave.google.com/wave/"]

    Random thought…

    The default appearance is a bright green background for me (in FF, Chrome, and Safari) – anyone else? If this is the default, could it be changed to white?

    WAIT… It is now working.

    Per a comment on the wave you posted here is what I had to do. “substituting + for %252B” not just “%252”

    Here is my working code:
    [wave id="googlewave.com!w+rKwHWkEMW" color="#000000" bgcolor="#cccccc" font="Arial, Helvetica, sans-serif" server="https://wave.google.com/wave/"]

    I tried using the Wavr button and could not get it to work with the appropriate information. Strange. Replacing the wave id got things working after I removed the ‘B’ in the wave id.

    I hope this helps.

    Awesome, I’m sorry i didn’t catch the “b” in there. Yes, I’m working on the automatic id detection from the url but it’s a bit unstable. Thanks for letting me know!

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Wavr does not display anything’ is closed to new replies.