Wavr does not display anything (24 posts)

  1. garyploski
    Posted 5 years ago #

    I installed Wavr and tried pasting the url of a wave, a wave id only, and the sample wave id presented in the FAQs but nothing displays.

    Here is the test page:

    This is the code I have presently using the sample wave id from the FAQs:
    [wave id="googlewave.com!w+ig2e7T0UC" color="#ffffff" bgcolor="#000000" font="Arial, Helvetica, sans-serif"]

    Here it is with my wave
    [wave id="googlewave.com!w+BrKwHWkEMW" color="#ffffff" bgcolor="#000000" font="Arial, Helvetica, sans-serif"]

    Am I missing something?


  2. lucascaro
    Posted 5 years ago #

    Hi! i can see the example wave in there. I guess you need to use yours or a wave you're added to. Are you logged in to wave on the same browser? do you have the last version of wavr? (0.2.2)

  3. garyploski
    Posted 5 years ago #

    Yes, I am logged in to Wave on the same browser (FF 3.5.3).

    I have the latest version - 0.2.2.

    Using a different browser (Safari) I am prompted to login but I do not see anything - blank white space.

  4. garyploski
    Posted 5 years ago #

    I updated the code to be:

    [wave id="googlewave.com!w+BrKwHWkEMW" color="#ffffff" bgcolor="#000000" font="Arial, Helvetica, sans-serif"]

    I still see the same black background with no text.

  5. BjEurope
    Posted 5 years ago #

    I do have the same problem. Not a single page I visited with embedded waves so far displayed it properly. On some pages I can see a google wave preview window but clicking into it brings me to my personal inbox, not the embedded wave.
    Neither could I get the wavr plugin to work on my blog. I tried the full ID as garyploski used it, I tried only the alphanumeric part of the ID, I also tried it with just the part after the exclamation mark. Only difference I noticed to other wave users so far is, that the wave IDs on my account contain "!w%" rather than "!w+".
    Does anybody have an idea why this is not working? Do I have to make the public first?

  6. aigarius
    Posted 5 years ago #

    Make sure you make the wave public by adding public@a.gwave.com as a participant to your wave. Otherwise it will not be visible by anyone but you.

  7. garyploski
    Posted 5 years ago #

    @aigarius Thanks for the heads up.

    Hmm, searching for the account I was prompted with the following: public@a.gwave.com is not a Google Wave account.

    Here is the resolve to the issue noted above: http://lifehacker.com/5376138/google-wave-101

    I tried adding the user to my wave... Still no luck. My wave isn't viewable by me or anyone else when embedded into my site/a blog using this plugin. =\

  8. tinabargo
    Posted 5 years ago #

    @garyploski: Just click on the plus button beside the "Manage contacts" link. An "Add New Contacts" window will appear, and just type "public@a.gwave.com" in the field box. Even if it complains, just press Enter until it shows up in your contact list.

  9. garyploski
    Posted 5 years ago #


    Thanks for the suggestion. I tried adding public@a.gwave.com and received the following error:

    User does not have a Google Wave account.

    I think there have been many changes on the Wave servers and this is one of the casualties.

    Using the 'search' option in the contacts panel the result is:

    public@a.gwave.com is not a Google Wave account.

  10. garyploski
    Posted 5 years ago #

    I tried again, as things seem to work and then not work, repeat, in wave at random times.

    I 'added' public@a.gwave.com to my contacts list and tried adding it to the wave with no success.

    As you can see I tried this previously with the same result.

  11. lucascaro
    Posted 5 years ago #

    when you get the message

    public@a.gwave.com is not a Google Wave account.

    just ignore it and hit Enter, it will be added to your contacts list and you can drag it to any wave you want. a yellow message appears that says:

    [not-yet-implemented-user] gave everyone access.

    the wave should be public.

    good luck.

    Remember that wave is in a preview and still have some bugs and not implemented features.

  12. lucascaro
    Posted 5 years ago #

    Can you please try using any other public wave you find on your inbox?

    @BjEurope, the wave id should not have the %252 in it. That has to be replaced by a +

    Wavr's latest version (0.2.2) will try to guess the id from the url, so please try updating and using the "wave" button in your editor, and paste the full url for your wave (make sure to have only that wave opened when you copy the url).

    thanks for the feedback!

  13. garyploski
    Posted 5 years ago #

    Could someone provide a test configuration that works so I/other people can test Wavr? Two samples might be best. One using the googlewave.com server and another using the wavesandbox.com server.

    I've tried with other public waves, created new public waves, and the original wave but nothing seems to work.

    Thanks for the support and continued development of Wavr.

  14. lucascaro
    Posted 5 years ago #

    The following works for me with wavr 0.2.3 and wordpress 2.8.5:

    [wave id="googlewave.com!w+NcOxJo8SW"]

    [wave id="googlewave.com!w+NcOxJo8SW" server="https://wave.google.com/wave/"]

    that is a public wave i just grabbed.

    Thanks to you for keeping on trying!

  15. garyploski
    Posted 5 years ago #

    Some good news...

    The 'Public' account is now appearing in my test wave.
    I added it to my contact list.
    There is now text stating "Everyone has access to this wave."
    This [wave id="googlewave.com!w+NcOxJo8SW" server="https://wave.google.com/wave/"] worked when I put it into my post.

    The bad news...

    I switched out the wave id with my test wave and it did not load anything.

    Here is what I have:
    [wave id="googlewave.com!w+BrKwHWkEMW" server="https://wave.google.com/wave/"]

    Random thought...

    The default appearance is a bright green background for me (in FF, Chrome, and Safari) - anyone else? If this is the default, could it be changed to white?

    WAIT... It is now working.

    Per a comment on the wave you posted here is what I had to do. "substituting + for %252B" not just "%252"

    Here is my working code:
    [wave id="googlewave.com!w+rKwHWkEMW" color="#000000" bgcolor="#cccccc" font="Arial, Helvetica, sans-serif" server="https://wave.google.com/wave/"]

    I tried using the Wavr button and could not get it to work with the appropriate information. Strange. Replacing the wave id got things working after I removed the 'B' in the wave id.

    I hope this helps.

  16. lucascaro
    Posted 5 years ago #

    Awesome, I'm sorry i didn't catch the "b" in there. Yes, I'm working on the automatic id detection from the url but it's a bit unstable. Thanks for letting me know!

  17. skg
    Posted 5 years ago #

    Nothing I have tried works for me, all I get is a colored box after logging in and in my editor I do not even see the button mentioned to insert the wave. I inserted the wave tag and it does not work.

  18. lucascaro
    Posted 5 years ago #

    Hi skg, can you show me the post you mention? I think it might be a problem with the wave id.

  19. bleakgadfly
    Posted 5 years ago #

    Im having the same problems, only it worked perfectly for 5 hours ago. Now it wont display anything. Just to make sure, I tried two other Wave plugins with the exact same result.

    The page: http://bleakgadfly.me/?p=3
    The code: [wave id="googlewave.com!w+2320cmP1B"]

    As far as I can see, the plugin doesnt try to load wave.google.com/googlewave.com as neither Firefox nor Chrome detects any attempt to load anything from the mentioned URLs.

    The wave is public, I am logged in, it worked before I took a nap.

  20. bleakgadfly
    Posted 5 years ago #

    ... Nevermind. Seem to work again :S Must be something with wave.

  21. jesseluna
    Posted 5 years ago #

    I read through the posts here but can't get the wave to show on my blog.

    *added the wavr plugin and activated it
    *inserted wave embed code [wave id="googlewave.com!w+EgYVoUneD"]
    *added the Public contact to the wave

    This is the full URL to the wave: https://wave.google.com/wave/#restored:wave:googlewave.com!w%252BEgYVoUneD

    This is the blog page: http://www.jpluna.com/wordpress/2009/12/08/how-to-add-a-google-wave-to-your-blog/

    I'm running it on FireFox 3.3.5.

    Any help would be greatly appreciated.
    ~ Jesse

  22. JamesICT
    Posted 5 years ago #


    Same problem as many mentioned above, as in - nothing shows.

    Have gone over wave id and checked and checked - removed %252b and replaced with a '+' and also tried some of the wave id's mentioned above that DO work on others' sites. But absolutely nothing displays on my site.

    Happy to try anything to get it working if anyone has any ideas?


  23. omponk
    Posted 5 years ago #

    when iam trying...
    this plugin work on Wave Sandbox ID. but blank page on Wave


    any suggestion?

  24. lucascaro
    Posted 5 years ago #

    well, it shows a message saying that i must login. It must be an issue with google wave's embed API. Sadly, nothing we can do from this side of the server :S

Topic Closed

This topic has been closed to new replies.

About this Topic