Support » Plugin: Avatar Privacy » Wavatar, MonsterID und Kegel

  • Resolved Torsten

    (@knodderdachs)


    Hallo,

    ich habe nach dem Installieren mal ein wenig herumprobiert, welche Avatare mir am besten gefallen, falls der Kommentator der Nutzung nicht zustimmt oder halt kein Gravatar-Bild hinterlegt hat.

    Dabei ist mir aufgefallen, dass Wavatar und MonsterID scheinbar nicht funktionieren? Es werden dann keine Bilder angezeigt.

    Weiterhin ist mir aufgefallen, dass, wenn ich den Kegel auswähle, das Scrolling auf der Website langsam und abgehackt ist. Das kann ich mir gar nicht erklären, ist aber reproduzierbar. Sobald ich irgendetwas anderes auswähle, läuft es wieder flüssig.

    Grüße
    Torsten

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author pepe

    (@pputzer)

    Steht bzgl. Wavatar/MonsterID etwas in den Logfiles? Die sind insofern anders, als daß es sich um PNG-Dateien handelt und nicht um SVG-Dateien wie bei den anderen generierten Files. War das von Anfang an so (vor 1.0.2)? Falls ja, versuche einmal den Ordner wp-content/uploads/avatar-privacy/cache/ zu löschen. Evt. sind da noch fehlerhafte Bilder gecached.

    Bzgl. des Kegels vermute ich, daß das Rendering der SVG-Datei aufgrund des komplexen Farbverlaufs länger dauert. Das dürfte allerdings stark vom verwendeten Browser und der Graphikkarte, auf meinem MBP kann ich das Phänomen nicht reproduzieren.

    Plugin Author pepe

    (@pputzer)

    @knodderdachs: Noch etwas zu den Wavatars/MonsterIDs, hast Du evt. ein Bildoptimierungs-Plugin installiert (oder ein anderes Plugin, das sich in WP_Image_Editor einhängt)? Falls ja, steht sehr wahrscheinlich im Error-Log etwas bzgl. “Streams”. EWWW Image Optimizer hab ich explizit getestet, damit funktioniert alles, aber es wäre denkbar, daß andere Plugins meine Image_Stream-Implementierung nicht mögen.

    Torsten

    (@knodderdachs)

    Ich habe bei mir keine Logfiles aktiviert. Dein Plugin habe ich erst heute morgen installiert. Es war von Anfang an die aktuelle Version.

    Den Cache habe ich mal gelöscht. Das Verzeichnis wurde danach automatisch wieder angelegt und die Avatare werden angezeigt. Wavatar/MonsterID nicht. Bei Wavatar/MonsterID sind im cache Verzeichnis auch Verzeichnisse und Dateien neu angelegt worden, allerdings ist die Dateigröße 0.

    Im Backend werden die Wavatar/MonsterID natürlich auch nicht angezeigt. So sieht es bei mir aus: https://www.pic-upload.de/view-35357799/ap.jpg.html

    Ja, ich verwende einen Bildoptimierer (https://optimus.io/). Der sollte eigentlich mit PNG funktionieren. Zumindest gab es bisher keine Probleme damit; muss aber nichts heissen. Eventuell verträgt es sich mit Avatar Privacy nicht richtig.

    Plugin Author pepe

    (@pputzer)

    Es liegt nicht an den PNG-Dateien selbst, sondern an den Dateioperationen, die Optimus auf den von mir übergebenen Stream auszuführen versucht. Ich werd einmal schauen, ob ich das mit der kostenlosen Version reproduzieren kann.

    Torsten

    (@knodderdachs)

    Okay, vielen Dank schon mal für deine Hilfe.

    Plugin Author pepe

    (@pputzer)

    Hallo @knodderdachs!

    Leider konnte ich das Problem mit Optimus (ohne HQ) nicht reproduzieren. Kannst Du bitte einmal das PHP-Fehler-Logging aktivieren und dann den Cache-Ordner löschen?

    Torsten

    (@knodderdachs)

    Hier der Auszug aus dem PHP-Log:

    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    [21-May-2018 15:14:09] WARNING: [pool www] child 20236 said into stderr: "libpng warning: Interlace handling should be turned on when using png_read_image"
    Plugin Author pepe

    (@pputzer)

    Mehr nicht? Das ist leider weniger konkrete Information, als ich mir erwartet hatte. Soweit mich mein Google-Fu nicht verläßt, sollten diese Warnings keine direkten Auswirkungen haben (sie deuten allerdings auf eine veraltete libpng hin).

    Irgendwelche anderen Plugins, die irgendetwas mit Bildern zu tun haben könnten? Wie hoch ist das memory_limit?

    Torsten

    (@knodderdachs)

    Nein, sonst steht nichts drin.

    Mein Hoster hat libpng 1.5.13 installiert (habe ich gerade selbst überprüft).

    Das Memory Limit steht bei 512MB.

    Ansonsten habe ich nichts installiert, das die Bilder irgendwie anfasst.

    Plugin Author pepe

    (@pputzer)

    Die PNG-Version sollte aktuell sein, dann ist es doch etwas anderes. Welche PHP-Version verwendest Du? Kannst Du bitte einmal versuchen, Optimus zu deaktivieren und zu schauen, ob der Fehler dann noch auftritt? (Dazwischen bitte immer den cache-Ordner löschen.)

    Torsten

    (@knodderdachs)

    Ich verwende PHP 7.2.

    Habe Optimus mal deaktiviert, den Cache gelöscht und ausprobiert. Funktioniert leider nicht. Ich glaube auch nicht, dass die Bilder überhaupt von Optimus verarbeitet werden, da dann normalerweise auch .webp-Dateien generiert werden müssten. Da das hier nicht geschieht, gehe ich davon aus, dass die Bilder unverändert bleiben. Auch an den Dateigrößen habe ich eben keine Unterschiede feststellen können.

    Plugin Author pepe

    (@pputzer)

    Ja, das spielt dann wohl keine Rolle. Ich weiß, es wird jetzt wahrscheinlich mühsam, aber könntest Du eine minimale Site bauen, in der nur Avatar Privacy aktiviert ist? Wenn’s dort immer noch nicht geht, liegt es in irgendeiner Form an der Host-Umgebung. (Evt. dort auch xdebug aktivieren, dann sollten wir einen Stack-Trace zu den Warnings bekommen.)

    Torsten

    (@knodderdachs)

    Gut, dass wird aber etwas bei mir dauern. Melde ich dann die Tage nochmal. Danke für deine Hilfe.

    Plugin Author pepe

    (@pputzer)

    Evt. würde es auch helfen, temporär xdebug auf der normalen Site zu aktivieren. Sollte bis auf eine Verlangsamung keine direkten Auswirkungen haben. Dann wüßten wir zumindest, wo diese Warnings generiert werden.

    Torsten

    (@knodderdachs)

    So, habe doch noch schnell ne neue WordPress-Installation aufgesetzt. Beim gleichen Hoster natürlich. Allerdings zeigt sich dort das gleiche Verhalten, wie bei meiner Website. Auch das PHP-Fehlerlog ist identisch. xdebug kann ich auf Uberspace 7 nicht installieren.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Wavatar, MonsterID und Kegel’ is closed to new replies.