Support » Plugin: Chatbot with IBM Watson » Watson Assistant Plugin does not work anymore…

  • Resolved estebanp

    (@estebanp)


    When i try setup our credentials in the Plugin, no type of data provided by IBM from Watson Assistant Services works.

    The message:

    Please ensure you entered a valid workspace URL (404). Click here for debug information.

    {
    “error”: “Resource not found”,
    “code”: 404
    }

    Skill Details
    Skill name:InterPlazaHotel
    Skill ID:0fb914d4-e052-4df5-afc5-32899e0b91e5
    Workspace ID:f85ac2dd-0c58-40d2-9ff0-9d6d25502656
    Skill URL:https://gateway-wdc.watsonplatform.net/assistant/api/v1/workspaces/0fb914d4-e052-4df5-afc5-32899e0b91e5/message
    Service Credentials
    Credentials name:auto-generated-apikey-1d0f4a59-c393-46bb-b6b7-a1ba4323cae7
    Username:apikey
    Password:qF4PnPUoWv9J28uwaNcRuOJPeiYVeLsgnb_eLAeys8z3
    Credentials name:auto-generated-apikey-601c9b1f-6755-4e5d-8189-f9ee22eebaab
    Username:apikey
    Password:hLaeZG7ckp4RZHrvpw-vzHD4T3JDWszrI5pF4R52wwwN

    Please, is there someone to provide support?

    Thanks,
    Esteban.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Support intelahelp

    (@intelahelp)

    Hello Esteban.
    Today we are going to release a new version of plugin that should address this issue. Sorry for inconvenience.
    Please don’t paste passwords on this forum.

    Plugin Support intelahelp

    (@intelahelp)

    Watson Assistant WordPress plug-in version 0.7.9 is released. Now plugin supports Watson Assistant API v2. Please make sure your plug-in is up to date.

    To make use of the new API please update “Assistant URL” at your plug-in settings.

    I have the same problem. Today update the pluggin and it still does not work. I put the password, the path and as a user “apikey” and it shows me the error

    Please ensure you entered a valid Assistant URL (404).
    {
    “code”: 404,
    “error”: “Not Found”
    }

    Plugin Support intelahelp

    (@intelahelp)

    Hello @dotsinteractive.
    To solve your problem we need extended information about your plugin installation and Watson Assistant credentials you are entering into plugin. To get the file with the extended information, follow these steps:

    • Go to your WordPress Dahsboard (sample screenshot)
    • Go to “Watson Assistant” > “Set Up Chatbot” in the left menu (sample screenshot)
    • On the “Set Up Your Chatbot” page go to “Having Issues?” tab (sample screenshot)
    • On the “Having Issues?” tab, download full log file with extended information by following the link. (sample screenshot) Don’t publish it openly on sites like WordPress Forums as it may contain sesitive information.
    • Send email with description of your issue and attached file to help@intela.io

    Please note that we need both extended inforamtion file and Watson Assistant credentials. Don’t post them on the forum, send them to help@intela.io instead.

    If you have more questions, don’t hesitate to ask them.

    I setup Watson plugin with right assistant url [V2] and credentials. But I am not getting any response back. I tested bot outside wordpress it is working fine. How can I troubleshoot?

    Plugin Support intelahelp

    (@intelahelp)

    Hello @rajeevsh.
    Thank you for contacting us.
    To solve your problem we need extended information about your plugin installation. To get the file with the extended information, follow these steps:

    • Go to your WordPress Dahsboard (sample screenshot)
    • Go to “Watson Assistant” > “Set Up Chatbot” in the left menu (sample screenshot)
    • On the “Set Up Your Chatbot” page go to “Having Issues?” tab (sample screenshot)
    • On the “Having Issues?” tab, download full log file with extended information by following the link (sample screenshot). Don’t publish it openly on sites like WordPress Forums as it may contain sesitive information.
    • Send email with description of your issue and attached file to help@intela.io

    If you have more questions, don’t hesitate to ask them.

    Plugin Support intelahelp

    (@intelahelp)

    Hello @rajeevsh.

    We haven’t heard from you recently.
    Do you still have any questions or need our assistance?
    We will gladly help you.

    • This reply was modified 1 year, 11 months ago by intelahelp.

    me three, just updated my credentials from v1 to v2 and voila .. it’s not working now.

    Plugin Support intelahelp

    (@intelahelp)

    Hello @paranoidandroid88.

    To solve your problem we need extended information about your plugin installation and Watson Assistant credentials you are entering into plugin. To get the file with the extended information, follow these steps:

    • Go to your WordPress Dahsboard (sample screenshot)
    • Go to “Watson Assistant” > “Set Up Chatbot” in the left menu (sample screenshot)
    • On the “Set Up Your Chatbot” page go to “Having Issues?” tab (sample screenshot)
    • On the “Having Issues?” tab, download full log file with extended information by following the link (sample screenshot). Don’t publish it openly on sites like WordPress Forums as it may contain sensitive information.
    • Send email with description of your issue and attached file to help@intela.io

    Please note that we need both extended information file and Watson Assistant credentials. Don’t post them on the forum, send them to help@intela.io instead.

    If you have more questions, don’t hesitate to ask them.

    Plugin Support intelahelp

    (@intelahelp)

    Hello @paranoidandroid88.

    We haven’t heard from you recently.
    Do you still have any questions or need our assistance?
    We will gladly help you.

    Update 1: I was using the wrong URL. I accidentally used the instance URL (in the Resource List) instead of the specific bot’s URL (in the bot’s settings).

    Update 2: yes it is OK to leave prefilled username if you use the correct URL 🙂

    ———
    Original message:

    This isn’t resolved. I just installed the plugin today and encountered a similar error.

    Please ensure you entered a valid Assistant URL (404). Click here for debug information.

    {
    “code”: 404,
    “error”: “Not Found”
    }

    IBM Assistant dashboard only offers an API key and URL field, yet the plugin still has a username field, which is prepopulated with the string “apikey,” is this OK?

    • This reply was modified 1 year, 10 months ago by brucetm.
    • This reply was modified 1 year, 10 months ago by brucetm.
    • This reply was modified 1 year, 10 months ago by brucetm.
    Plugin Support intelahelp

    (@intelahelp)

    @brucetm.
    We are glad that everything works for you now.
    Thank you for letting us know.

    Hi, I need help. my chatbot not works. Not enable a conversation.
    I using a last plugin version.
    I using a last wordpress version.

    Look: http://www.netsulminaswebhost.com.br/v1

    Plugin Support intelahelp

    (@intelahelp)

    Hello @agvm2000.
    We released the new version of plugin (0.8.19) that has the fix to your issue. Please update your plugin to the latest version and let us know if the issue persists.

    SOLVED!!!!! AFTER UPDATE!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Watson Assistant Plugin does not work anymore…’ is closed to new replies.