WordPress.org

Forums

Image Watermark
Watermarks not showing or applying (11 posts)

  1. Dearheartbeauty
    Member
    Posted 2 years ago #

    Hi there, I installed this plugin and included the settings automatic OFF, manual ON, as I wish to be able to manually apply a watermark to all images I own but this does not seem to me working. I've uploaded a jpg image, chosen the position and a scaled option and tried to apply a watermark to certain images using the media library but nothing shows up. Please could you assist me?

    Lauren

    http://wordpress.org/plugins/image-watermark/

  2. dFactory
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @Dearheartbeauty,

    Can you post a link to your site, if possible, on our support forum (in case we need some more details, it would be easier to handle it there)

  3. misad91
    Member
    Posted 1 year ago #

  4. dFactory
    Member
    Plugin Author

    Posted 1 year ago #

    @misad91 - your images are displayed in a very "non-wordpress" way. Difficult to describe it here, but the main issue there might be is that images presented on your website are not generic image sizes I think.

    Ask the theme author, what image sizes he/she is using in that theme, then set the watermark to be applied to the image sizes you want, apply watermark to 1 image and see if it works (looking at that in your Media Library).

    But I must tell you, the way that your theme is built might cause you trouble not only with watermarks, but many other plugins.

  5. v_r_boy
    Member
    Posted 1 year ago #

    I have the same issue on my local installation. I use Wave theme (demo: http://themes.danyduchaine.com/wave/ )

    also, I don't see any option in Media Library for applying watermark to previously uploaded images.

  6. dFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Did you enable watermarking? And did you enable manual watermarking in plugin settings too?

  7. v_r_boy
    Member
    Posted 1 year ago #

    yes I did. this is my settings http://imgur.com/HAtgWjs

    it does apply to new uploads however. is there any option for repeating watermark ? doesn't look good to have one big name all over it. small repeat image is much better

  8. dFactory
    Member
    Plugin Author

    Posted 1 year ago #

    Not, there is no such option. But you coud prepare a repeating watermark image in PhotoShop or anything elese you are using, and apply that to images.

    One thing from your settings: applying watermark to full size images is not recommended (remember: it is your original file).

  9. v_r_boy
    Member
    Posted 1 year ago #

    dFactory, My settings were correct, right? how can I fix it? I can't apply watermark on existing images.

  10. v_r_boy
    Member
    Posted 1 year ago #

    can you post a screenshot on media gallery where I can apply watermark manually? I can't find anything like that here

  11. dFactory
    Member
    Plugin Author

    Posted 1 year ago #

    If watermarking and manual watermarking are enabled in plugin settings you'll see a new option - "Apply watermark" under Bulk action dropdown in Media Library. Works just like other bulk actions in WordPress

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Image Watermark
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic