Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Watermark not working

  • Resolved Buchtic1


    I would like add watermark to my gallery, but this not working.
    In Other Options I have set Image URL ./wp-content/gallery/watermark-transparent.png (is only working option) and on preview image watermark is displayed.
    Any help?

    Operating System : Linux (64 Bit)
    Server : Apache/2.2.16 (Debian)
    Memory usage : 76.36 MByte
    MYSQL Version : 5.1.66-0+squeeze1
    SQL Mode : Not set
    PHP Version : 5.3.3-7+squeeze16
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off
    PHP Memory Limit : 128
    PHP Max Upload Size : 16M
    PHP Max Post Size : 17M
    PCRE Backtracking Limit : 4194304
    PHP Max Script Execute Time : 20s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library
    GD Version : 2.0
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : Yes
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : No
    JIS-mapped Japanese Font Support : No

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m not sure about the server settings you have. This should work in most environments, but after spending days trying to figure it out myself, I found a fix which just made NextGen worth every penny!

    For anyone else having a problem with the .png watermark not displaying or showing on your NextGen Gallery images (even though it’s showing on the thumbnail during option setup), here’s a fix I found. Having explored dozens of other possibilities, I’m betting this solves the problem for most of you.

    When designating your watermark, use an absolute path. Most of us have assumed it meant something like this example: – But this will not work.

    You need an absolute path that looks more like this example:


    So how do you determine your “absolute path”?

    In Mac, create a new text file. Make sure it’s PLAIN TEXT, not RICH TEXT. You can choose that option in the format dropdown. For Windows, launch Notepad. What we’re trying to do here is use a PLAIN TEXT editor. We want to avoid using Word. That’s a discussion for later.

    After you created a new plain text file, place this code in it:

     $path = getcwd();
     echo "Your Absolute Path is: ";
     echo $path;

    Save the file as “abspath.php” in the same folder as the watermark image.

    Now with your FTP program, upload the file. Again – upload this file to the same folder holding your watermark image!

    Visit the URL to this file in your web browser:

    You will see this page display the REAL absolute path you’re looking for.

    Copy that convoluted looking absolute path into your Worpress/NextGen watermark options and paste that as the path FOLLOWED by:


    So, it will ultimately look something like this:

    Forgive me for being “wordy”, but I know there are many who aren’t programmers and I think a little more info sometimes helps.

    Thanks. You are god.
    It’s working. 🙂

    I wish I was, but I’m glad it helped! Thanks for the shout back.

    Plugin Author photocrati


    @calisportbiker – Thank you very much for that detailed explanation! I will be making note of this topic for our developers to review as well.

    – Cais.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Watermark not working’ is closed to new replies.