WordPress.org

Forums

WassUp Real Time Analytics
Wassup won't activate (after already deactivating it) (2 posts)

  1. voodoochild16
    Member
    Posted 2 years ago #

    Hey all, I have the latest version of Wassup, and the latest version of WordPress. I have been using Wassup for over a year (maybe even two years now) and for the first time I deactivated it because I was trying to find the reason why my comments form wasn't working (which turned out to the official Facebook plugin's fault).

    Upon reactivating the Wassup plugin, the page just kept loading and loading and nothing changed, it just stayed hanging the whole time and it wont stop until I click on the X button in Firefox. I also use the plugin next to Wassup Real Time Analytics which is Wassup keywords. That one activates fine, what do you guys think the issue is?.

    Would it be possible that there is so much data collected from so many months of traffic?. I even tried installing a fresh copy of Wassup and it still didn't activate, I think it's a plugin that I already have activated that is making this one not activate.. but I'm just not sure...

    http://wordpress.org/extend/plugins/wassup/

  2. helened
    Member
    Plugin Contributor

    Posted 2 years ago #

    Wassup is indeed known to take a long time to activate when it's dataset is large, especially on slow or shared servers. This has caused browser timeouts (Firefox) and confusion as to whether the plugin activated or not (see http://wordpress.org/support/topic/plugin-wassup-latest-update-killed-blog). If you don't get a fast "Activation Failed" message, then Wassup does eventually activate. It just takes a longer time than WordPress or your browser timeout limit allows. Wassup continues the activation process even after a user abort (X clicked in browser).

    Wassup rebuilds it's table indices at every activation/upgrade. This MySQL operation can slow down your site and can affect server CPU activity and it is why I strongly recommend upgrading Wassup only when your site is idle or is least busy (no visitors, or very few visitors).

    In the future, if you ever need to deactivate plugins to isolate a problem on your site, try instead, Uncheck "Enable/Disable Recording", in Wassup >> Options >> [Statistics Recording] Tab. This stops most of Wassup's plugin activity in WordPress and avoids the index rebuild that reactivation would cause. You will have to remember to re-check this option to resume tracking visitors afterwards, though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WassUp Real Time Analytics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic