Support » Plugin: WP Security Audit Log » Was working great-no post edit function now

  • Resolved protechs2


    Thanks, very nice plugin, used to work grea. But since the flurry of WP updates, it started flipping php errors and would not allow the Edit Post action – it now just returns a blank screen even THOUGH it completed the action. You have to go back, view, edit and try again to do any other update. Here’s the new error: PHP Fatal error: Cannot unset string offsets in /home/username/public_html/blog/wp-content/plugins/wp-security-audit-log/inc/WPPHEvent.php on line 1819.
    I installed update this morning thinking it would be okay–no.
    Theme is older but working fine still.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author WPWhiteSecurity



    First of all thank you for showing interest in our plugin and for reporting back such issue.

    We are currently looking into what might have cause such issue, but for now I recommend the following as a workaround:

    1. Disable our plugin and re-enable it again.
    2. Disable the following alerts: 2013 and 2036 from the “Enable / Disable Alerts” node.

    Once disabled the plugin should not give you any more problems but you will not get any alerts once a category is changed. This is only until we find a fix, which should be available in the next update of our plugin.

    Should you have any further queries, do not hesitate to drop us an email on

    Have a great day.



    I’m having the same issue. Updating any posts result to a white screen. Also, it looks like admin pages run slower if this plugin is activated. I ended up disabling it completely.

    I believe it was working fine prior to WP 3.7.

    Plugin Author WPWhiteSecurity


    Hi Martinjgonzales,

    As explained in the previous post please disable the following Alerts from the “Enable/Disable Alerts node” – 2013 and 2036. This should allow you to continue working.

    In the meantime we are working on a fix.

    Should you have any further queries, do not hesitate to get in touch and thank you for reporting the issue.

    Have a great day!

    I’m having the same issue. Have disabled the alerts as recommended. Looking forward to a fix. Thanks. 🙂

    Plugin Author WPWhiteSecurity


    Hello everyone.

    Even though we tracked down the issue it seems it is triggered only in some very specific places.

    We would appreciate if everyone who has such issue gets in touch with us on so we can give you a temporary patch so we test that the patch works in your environment.

    Looking forward to hearing from you and sorry for any inconvenience caused.

    Plugin Author WPWhiteSecurity


    Alternatively you can try the fix yourself and report to us back if the fix worked. To apply a fix, please follow the below procedure:

    1. Open the file WPPHEvent.php which can be found in \wp-content\plugins\wp-security-audit-log\inc directory

    2. Go to line 1805

    3. Next to the curled bracket, add the following text “return true;”. So after the fix line 1805 should be { return true;

    That should be it. Should it fix your issue, we would be glad if you update this ticket.

    Thank you very much and looking forward to hearing from you.

    Plugin Author WPWhiteSecurity


    Hi all,

    Sorry for the delay. Fixed this issue with the latest update of the plugin. Please update to version 0.5.1 for the fix.

    Thank you for showing interest in our plugin and do not hesitate to get in touch should you have any queries or encounter any problems.

    Stay secure!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Was working great-no post edit function now’ is closed to new replies.