Was I just hacked? HELP!! (9 posts)

  1. wildbug
    Posted 6 years ago #

    I just checked with my web host and they say all diagnostics look okay, my server is fine, and they can access my site, and my WP Admin panel fine.

    Here is my site: planetthrive.com

    Twice today this happened: I tried publishing a post and then the screen when blank (white) and the status bar was wildly jumping from "waiting for planetthrive.com" to "connecting to planetthrive.com" etc. This happened for both the admin panel and the website itself.

    In a few minutes it resolved on its own.

    A while later, the same thing happened; I clicked on "publish" for a new post and now I cannot access the site or admin panel. This time its lasting much longer and has not resolved. But my web host can access both URLs. They say it's my computer. I have a Mac G4.

    Can anyone shed light on what is happening? I never had this happen before. I just switched to WP a few weeks ago...

    Thanks for any insight.

  2. wildbug
    Posted 6 years ago #

    Weird, so now I can access both again...AND I just re-tried publishing a new post and it was successful.

    Is there a file I can search in terms of checking to see if I was hacked?

    Has anyone ever heard of this issue before?

  3. esmi
    Forum Moderator
    Posted 6 years ago #

  4. wildbug
    Posted 6 years ago #

    Thank you Esmi. I installed that plug in and this is the result of the security scan - can you advise on the bolded items below? I'm not sure if I should click on the link to change the table prefix or what to do about the .htaccess file. How would I tell if my site has been hacked? Many thanks!!:

    Initial Scan
    WordPress version: 2.8.4 You have the latest stable version of WordPress.

    Your table prefix should not be wp_. Click here to change it.

    Your WordPress version is successfully hidden.

    WordPress DB Errors turned off.

    WP ID META tag removed form WordPress core

    No user "admin".

    The file .htaccess does not exist in wp-admin/.

  5. esmi
    Forum Moderator
    Posted 6 years ago #

    You can change thr able prefix manually. see http://tdot-blog.com/wordpress/6-simple-steps-to-change-your-table-prefix-in-wordpress

    Or you can try using a plugin:


    Which ever method you use, make sure that you back up your database first.

    With regard to the .htaccess password protection of wp-admin, see http://codex.wordpress.org/Hardening_WordPress#Securing_wp-admin

  6. NHNightOwl
    Posted 6 years ago #

    I tried to add this plugin to my site. It said that "Plugin installed successfully" but when I tried to Activate the Plugin I got the following error....

    This webpage is not available.

    The webpage at http://gaymuscles.net/wp-admin/plugins.php?action=activate&plugin=wp-security-scan%2Fsecurityscan.php&_wpnonce=2d0311499f might be temporarily down or it may have moved permanently to a new web address.

    Any help or ideas?? I host at Webair.com and some of my blogs are updating fine and others won't update or install plugins... HELP!

  7. wildbug
    Posted 6 years ago #

    Thank you Esmi, that was helpful. With regard to the security result "The file .htaccess does not exist in wp-admin/" does that mean I am missing a file? Your response only addressed password protection and I am unsure how that is related to the security result above.

    ALso, I still don't know how to tell if I was hacked. Is there any way to tell?

    THank you!!

  8. wildbug
    Posted 6 years ago #

    Oh geez, I just spent 3 hours correcting a problem created by following these directions: http://tdot-blog.com/wordpress/6-simple-steps-to-change-your-table-prefix-in-wordpress

    It did not work as directed. I ended up with duplicate tables in my database somehow and could not rename all the wp_ tables. It took hours for my web host to help me - I finally had to create a new database and restore the old backup.

    What a pain!

    I just wanted to know if my site was hacked or not....

  9. esmi
    Forum Moderator
    Posted 6 years ago #

    I can't see any evidence of hacking on the site. Your problems could be caused by a bad plugin or an issue in your theme. Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

Topic Closed

This topic has been closed to new replies.

About this Topic