WordPress.org

Forums

Warnings: Illegal offset type - after fresh install (10 posts)

  1. erika_conn
    Member
    Posted 7 years ago #

    Fresh install. Got the following errors:
    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 125

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 131

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 139

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 144

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 281

    Warning: Illegal offset type in unset in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 282

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 125

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 131

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 139

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 144

    Warning: Illegal offset type in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 281

    Warning: Illegal offset type in unset in /home/cecon46/public_html/saycheese/wp-includes/cache.php on line 282

  2. whooami
    Member
    Posted 7 years ago #

  3. ROMbler
    Member
    Posted 7 years ago #

    I just got the same thing. Checking my themes it says
    "Array Array Array
    All of this themes files are located in Array"

    The two default themes are listed under Broken Themes and show that the template is missing. I uploaded an new theme and it shows the same error.

    Don't know what's going on.

  4. erika_conn
    Member
    Posted 7 years ago #

    I got the same as you. What's with the Array, Array, Array? It does ring a bell, though.

  5. erika_conn
    Member
    Posted 7 years ago #

    Hi whooami,

    I did as you suggested by downloading your cache.php. The previous warnings disappeared and now I have the following:

    Warning: htmlspecialchars() expects parameter 1 to be string, array given in /home/cecon46/public_html/saycheese/wp-includes/formatting.php on line 544

    Warning: htmlspecialchars() expects parameter 1 to be string, array given in /home/cecon46/public_html/saycheese/wp-includes/formatting.php on line 544

    Warning: htmlspecialchars() expects parameter 1 to be string, array given in /home/cecon46/public_html/saycheese/wp-includes/formatting.php on line 544

    And you help?
    This is a new site:
    http://www.ceconn.com/saycheese

  6. whooami
    Member
    Posted 7 years ago #

    put back the old cache.php and try this;

    http://wordpress.org/support/topic/131652/page/2?replies=31

    (all im doing is searching, and providing links to other suggestions)

  7. erika_conn
    Member
    Posted 7 years ago #

    I meant Can You Help.

  8. erika_conn
    Member
    Posted 7 years ago #

    Well now I'm really confused. It's changed again to Illegal Offset type

  9. erika_conn
    Member
    Posted 7 years ago #

    You're a genius, whooami. Thank you so much. All those bad warnings went away.

  10. ROMbler
    Member
    Posted 7 years ago #

    Thanks, whooami! I restored the original cache.php and changed the line in \plugin.php according to the link and that fixed it.

Topic Closed

This topic has been closed to new replies.

About this Topic