Support » Fixing WordPress » Warnings and errors displayed with wp debug set to false

  • Resolved snippet24

    (@snippet24)


    This is a temporal test WordPress installation, and the problem is warnings and errors are shown, not sure what to do so far I have tired.
    1. set
    define( 'WP_DEBUG', false );
    2. checked for ini php files (didn’t find them)
    Perhaps should I contact the hosting provider?

    • This topic was modified 4 months, 2 weeks ago by snippet24.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Howdy!

    Does that happen if you deactivate all plugins and use a bundled theme like Twenty Twenty Two/One?

    That’s the first thing I would do to see where that is coming from.

    Thread Starter snippet24

    (@snippet24)

    Thank you!!
    I tried switching to another theme and “creating an error/warning”, and it did display the warning, so my theme should not be the cause of this? Tried as well disabling the “new plugins”, no diference but I haven’t disabled all yet.

    Warning: Use of undefined constant ocurrenunerror – assumed ‘ocurrenunerror’ (this will throw an Error in a future version of PHP) in /home/tomastes/public_html/test-back/wordpress/wp-content/themes/twentyfifteen/header.php on line 34
    ocurrenunerror

    Already contacted the hosting so they should be looking into it.

    • This reply was modified 4 months, 2 weeks ago by snippet24.
    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Right, the theme is not causing that. It sounds like a plugin is being weird and causing some wonkiness.

    Thread Starter snippet24

    (@snippet24)

    Right, the theme is not causing that.

    Alright!

    It sounds like a plugin is being weird and causing some wonkiness.

    At this point I disabled all the plugins I could without breaking the site (like ACF), and no improvements.

    • This reply was modified 4 months, 2 weeks ago by snippet24.
    • This reply was modified 4 months, 2 weeks ago by snippet24.
    Thread Starter snippet24

    (@snippet24)

    Okey figured out using the following code in wp-config worked

    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);
    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Happy to hear that works.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.