Support » Plugin: Log Deprecated Notices » Warnings after updgrade to Buddypress 1.7

  • After upgrading to Buddypress 1.7 I get these warnings on page loads:

    Notice: Undefined index: file in C:\Devel\site\project\htdocs\wp-content\plugins\log-deprecated-notices\log-deprecated-notices.php on line 245
    
    Notice: Undefined index: line in C:\Devel\site\project\htdocs\wp-content\plugins\log-deprecated-notices\log-deprecated-notices.php on line 246

    The problem is that the mentioned lines expect doing_it_wrong to be at position 4 in the debug_backtrace array. And on my site it is now on position 3.

    I don’t know why the position in the array has changed after the upgrade, but it would probably be a good idea to locate it in a different way than hardcoding the position.

    http://wordpress.org/extend/plugins/log-deprecated-notices/

Viewing 1 replies (of 1 total)
  • Erwan

    (@erwanlescop)

    Same here (notice, not error / warning hence not critical!), probably due to BP 1.7 too.

Viewing 1 replies (of 1 total)
  • The topic ‘Warnings after updgrade to Buddypress 1.7’ is closed to new replies.