Support » Plugin: Members - Membership & User Role Editor Plugin » Warnings after update to 3.0.2

  • Resolved skirridsystems

    (@skirridsystems)


    When I go to edit a page on my site I see these two warnings at the top of the screen.

    Warning: in_array() expects parameter 2 to be array, bool given in xxx/wp-content/plugins/members/members.php on line 446
    Warning: Cannot modify header information – headers already sent by (output started at xxx/wp-content/plugins/members/members.php:446) in xxx/wp-admin/admin-header.php on line 9

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same issue here.

    Plugin Author Caseproof

    (@caseproof)

    Hi there,

    Thanks for the report! This will be fixed in the next release. For now, since it’s a warning rather than an error, it shouldn’t cause any actual problems.

    Also, just to note in the meantime, you’re likely seeing the warning because you have WP_DEBUG enabled. If you set WP_DEBUG_DISPLAY to false, and WP_DEBUG_LOG to true, these notices will log to your debug.log file instead of printing to your screen.

    -RV

    Ho anch’io avuto questo errore, ma utilizzando lo stesso le pagine e gli articoli, il sistema mi ha dato problemi nella pagina di login tanto che ho dovuto ricorrere al sistema di ripristino di wordpress per accedere normalmente alla bacheca. Ciò mi ha consentito di controllare cosa non andava e ho potuto disattivare il plugin memers.

    I also have this issue after updating a client’s site to the latest version and doing some debugging.

    Is there an ETA on when the version with the fix will be available?

    Thanks in advance. 🙂

    • This reply was modified 2 years, 2 months ago by one3rdnerd.

    Buongiono, dopo aver aggiornato wordpress alla versione 5.4 ho riscontrato il seguente errore:
    Warning: in_array() expects parameter 2 to be array, boolean given in /web/htdocs/home/wp-content/plugins/members/members.php on line 446
    L’errore risiende in questa funzione in members.php
    public function block_editor_assets(){

    $active_addons = get_option( 'members_active_addons' );
    		if ( !in_array( 'members-block-permissions', $active_addons ) ) {

    $active_addons deve essere incluso in array altrimenti figura sempre l’errore che i parametri array sono 2 e non 1.
    La modifica apportata è questa:
    if ( !in_array( 'members-block-permissions', array($active_addons) ) ) {

    Il plugin è members ed ho adattato l’array a php 7. Spero di essere stato di aiuto.
    Buona giornata.

    • This reply was modified 2 years, 2 months ago by kratos839.

    @caseproof this is actually quite annoying on a dev environment as the admin screen becomes useless when notices are triggered.

    Do you have an open git so we can help you with pull requests?

    Cheers

    @caseproof I have WP_DEBUG set to false but still see these errors.

    Thread Starter skirridsystems

    (@skirridsystems)

    Try this instead:

    ini_set(‘display_errors’,’Off’);
    ini_set(‘error_reporting’, E_ALL );
    define(‘WP_DEBUG’, false);
    define(‘WP_DEBUG_DISPLAY’, false);

    @skirridsystems ah, that worked.

    But is this issue causing any other problems or breaking functionality? Or is it fine?

    Version 3.0.3 is now available and fixes this issue.

    It was strange that the error was appearing when WP_DEBUG was false for me as well.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Warnings after update to 3.0.2’ is closed to new replies.