Support » Plugins and Hacks » [Resolved] WARNING: ZipArchive Class did not close successfully.

[Resolved] WARNING: ZipArchive Class did not close successfully.

  • I have had really good experience using Duplicator in the past, but have been having a hell of a time with a bunch of sites that I’m migrating from one server on Bluehost to WP Engine. I spoke to Bluehost tech support who does not seem to think the issue is with the memory usage, which is what it seems most issues with Duplicator revolve around.

    When I try to create a new package everything seems to work correctly, and no error shows up, but in the error log I always get:

    WARNING: ZipArchive Class did not close successfully.  This server or hosted segement might have a disk quota limit.  Please check your disk space usage to make sure you can store this zip file successfully.

    Both the .sql and .php files are created successfully. Has anyone received this error before and gotten around it?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Cory Lamle


    Hey mijogu,

    Here is a helpful section on the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: “3. Troubleshoot”
    -> See Area/Question: “What should I do when I see a warning in the log about ” disk quota issues”?”

    It could also be related to a permissions issues…


    Thanks, lifeinthegrid, but nothing I found there seems to work. The host keeps claiming there is “unlimited space” and that should not be the problem. Even if I get the files to zip down to next to nothing, the ZipArchive doesn’t close properly.

    Can I use Duplicator WITHOUT zipping any files? How would that change the procedure?

    Plugin Author Cory Lamle


    Hey mijogu,

    There really can’t have unlimited space because all hard-drives have a limit, that is their special way of saying we don’t want to help much ;)…

    As far as using the plugin without zipping that currently is available in this version…

    Have you tried using the directory filters found in the options dialog? If not then try the top most directories, one by one in your wordpress root. If it still won’t zip correctly then it could be one of two things:

    1. One of the files that the zip routine is trying to compress is corrupted or in rare cases a strict permission setting on a file may cause your version of PHP ZipArchive to fail.

    2. The underlying module that PHP ZipArchive calls is outdated. This can be found by going to Duplicator > Settings > Diagnostics Tab > Click Show/Hide PHP info. Look for a section that says something like this:

    Zip enabled
    Extension Version $Id: bdd35a2ede0347a3df239de1e7dc5d7e588f00c3 $
    Zip version 1.11.0
    Libzip version 0.10.1

    You may have to compare those values with a version that works on one of the other instances that you got working…

    Hope that helps!

    Plugin Author Cory Lamle


    Hey mijogu

    Any success with this issue?

    Nope. Unfortunately, none at all. Gave up on Duplicator and found more reliable way to migrate sites.

    I would still recommend beginners try Duplicator for themselves (those who are less comfortable exporting/importing databases), bc it worked great for me a couple of times. But I think from now on I’ll be using the WordPress recommended method which involves using the Search and Replace for WordPress Databases Script. I was able to move 6 sites in just a couple of hours with no issues… at least none that involved the migration. Highly recommend.

    Plugin Author Cory Lamle


    That stinks… Yeah the PHP ZipArchive class which is built into PHP as a module does rely on other libs that are on your current OS. Not to much I can do to fix the library as its complied into PHP.

    The Duplicator does include all the logic of the Search and Replace for WordPress Databases Script and quite a few other validation routines. One thing you will have to watch out for on that script is that it currently does not handle base64 encoded serialized PHP strings.

    Some plugins use this method to save there data. So if you do run into issues with a specific plugin you may have to check and see if its base64 encoded. If it is then you will have to manually base64_decode the string run the search tool then re-base 64 encode it, There are a few other scenarios that it doesn’t cover, but it should get you going on the majority of all your sites, hopefully in future version of the plugin we will handle more than just the PHP ZipArchive library…


    I’m having this same issue and like an earlier poster gave up on duplicator.

    Plugin Author Cory Lamle


    Hey llclj,

    Sorry your having issues… Hopefully with future updates the plugin will be able to validate or detect these issues…


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] WARNING: ZipArchive Class did not close successfully.’ is closed to new replies.