Support » Plugin: IP2Location Country Blocker » Warning, you are about to block your own country

  • Resolved obchodneninahoda


    Hi, I am currently installing IP2L to the websites we administrate, but I ran into a trouble.
    My goal is to block backend from all countries, except Czech Republic.
    On some of the websites, I get warned, however, that I am about to block my own country access and it says that my country is USA.
    Ho do I change it or what to do with it, please?
    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author ip2location


    Can you for to the IP Lookup tab and let us know the IP address detected? Due to privacy issues, please reply us directly to support [at] ip2location [dot] com.

    I have the same problem. Funny thing is: I do run three wordpress blogs in the same browser, all with the same version of databases for IP2L. Two of the websites tell me via IP Looktab Germany as Location (which is correct) and one website tells me US.

    How can that happen ? All lookup the same IP adress.

    Thanks for any help!

    Plugin Author ip2location


    It might be one of the rules that may block you. It will be useful if you can share the full screenshot of your settings page.

    I checked the lookup now again and now all 3 websites show the wrong country. Other services get the location right.

    For backend no settings are set beside allowing accces only for EU countries. Also no proxy. Frontend blocking is not enabled.

    In the settings: Detect Forwarder IP is active, deactivating it does not change anything.

    Database version:
    Database Date 2021-03-28

    Database Date 2021-04-12

    Both Binary Database

    • This reply was modified 2 years, 5 months ago by dragon013.
    Plugin Author ip2location


    @dragon013 Please report the IP address and location detected for investigation.

    Just sent a mail with the data. Thanks for looking into it!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Warning, you are about to block your own country’ is closed to new replies.