Support » Installing WordPress » Warning… wp-includes/taxonomy.php

  • Hi to everybody,

    I hope I’m in the right discussion. I’ve installed WP 2.7.1, a brand new installation, no upgrade, and I’m testing it on localhost. Now I found this strange behaviour. If I add/modify pages/posts as admin, everything works fine. If I do the same as Editor or Author I have the following messagge when I click on Update button:
    Warning: Invalid argument supplied for foreach() in /var/www/wp-includes/taxonomy.php on line 1953
    Warning: Cannot modify header information – headers already sent by (output started at /var/www/wp-includes/taxonomy.php:1953) in /var/www/wp-includes/pluggable.php on line 850

    When I edit the same page as ADMIN I have tthe following message on the top of the page:

    Warning: [username] is modifying this page.

    If I save the page again as ADMIN everything is fine.

    My running website is on WP 2.7 and doesn’t have this error. Should I downgrade the WP on localhost or is there a solution?

    Thanks to everybody

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi


    Forum Moderator

    This line
    /var/www/wp-includes/pluggable.php on line 850
    indicates the problem is related to a plugin. Did you by chance install something like MyCategoryOrder plugin, or another that modifies category order? It would be related to Category, Tag, or Link Category.

    If so, disable it and see if that resolves the problem.

    Deae All,

    thanks for your support.

    Following yours suggestions I disabled one by one all my plugins and found that the problem is with: User Access Manager.

    When I enable it I get the problem.

    Interpreting the error message on the base on the information in the link you sent me, I checked also the taxonomy file but it seems to me that there are not an excess of white space or similar.

    I will address my request to the plugin developer.

    Thanks again.

    Hi All,

    I’ve the same problem. 🙁
    This is new bug for latest version (
    I resolve this problem with it do downgrade plugin version to


    same prb:
    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/xxxxxx/public_html/wp-includes/taxonomy.php on line 1464


    AutoBlogged Diagnostic Tests
    Component Results
    AutoBlogged version v2.3.149: passed
    PHP version v5.2.8: passed
    WordPress version v2.8.1: passed
    MySQL version v5.0.81-community: passed
    XML extension Enabled
    PCRE extension Enabled
    Zlib extension Enabled
    mbstring extension Enabled
    iconv extension Enabled
    DNS test Passed
    cURL extension cURL Installed
    safe_mode: Disabled
    open_basedir: /home/xxxxxxxx/usr/lib/php:/usr/local/lib/php:/tmp

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/xxxxxxxxxxxx/public_html/wp-content/plugins/autoblogged/diag.php on line 239
    HTTP retrieval test Passed

    What seems to be the problem?

    I use autoblogged too and I get this error:

    Catchable fatal error: Object of class WP_Error could not be converted to string in taxonomy.php on line 1415

    Is there a solution?


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Warning… wp-includes/taxonomy.php’ is closed to new replies.