Support » Plugin: Slash Admin » Warning when using login logo

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    you are correct, this shouldn’t happen. I tried to replicate the problem locally, though, but to me all combinations of image sizes showed up as expected, with no warnings (debug mode was enabled, of course).

    Is it happening with any image that you put? If you try and upload a new image via the plugin’s “upload” button, will it still show this warning?

    Also, do you use the latest version of the plugin?

    Edit: one more question: Do you, by any chance, also get a warning mentioning allow_url_fopen like this:
    Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in C:\xampp\htdocs\test\wp-content\plugins\slash-admin\inc\login.php on line 16

    Hi,
    Thanks for the quick response.
    I did upload the image through the plugin’s upload button. I tried 2 jpgs and a png.
    I also tried it by uploading through the media area first but the same warning.
    I am using the latest version of the plugin v2.7.

    The warning in my first post was the only warning received.
    Some quick research about that php function suggest using relative path like /public_html/wp-content/uploads/2015/10/logo-login.png instead of absolute url like http://www.mydomain.com/wp-content/uploads/2015/10/logo-login.png

    can you make a change to the plugin’s inc/login.php file?
    On line 16, change

    list($width, $height) = !empty($image) ? getimagesize( $image ) : array('', '');

    to:

    list($width, $height) = !empty($image) && ini_get('allow_url_fopen') ? getimagesize( $image ) : array('', '');

    If this doesn’t work, can you send me the link of your login page, to see if I can figure something out by checking its html source? if you don’t want to post the url in public, you can send it to me with an email at contact [@] gsarigiannidis.gr

    Hi,

    I tried that change but still the same.
    I’ll email you direct the url.

    Since we managed to fixed it in our email communication, I am marking this topic as resolved.

    The fix will be included in the plugin’s next update. Meanwhile, if someone else encounters the same issue, please let me know.

    Will

    (@funkmasterbecks)

    Hi Giorgos,

    I’m facing the same issue. Would you mind sharing how to fix this ourselves?

    Hi Will,

    I had include the fix in some older update, so it should be working. In the topic starter’s case my guess was that it might have something to do with some server setting and the path that his WordPress was installed. I had tried to replicate the issue, both locally and on my own servers, but the only way that I could get the same error message was when I manually changed the image URL to make it inaccessible – for example, if the path was mysite.com/mysite/image.jpg and I would change it to mysite.com/image.jpg. But then, obviously, the image wouldn’t appear at all. In his case, though, the warning said that the image was not found but yet it would be displayed.

    So, what I eventually did was adding a test to see if the headers response is OK or not. If not, then getimagesize should not get called (see line 17 at inc/login.php: https://plugins.trac.wordpress.org/browser/slash-admin/trunk/inc/login.php#L17)

    I don’t know if that’s the case for you too, though.

    Will

    (@funkmasterbecks)

    That’s weird. I just tested it locally, and there’s no error.

    Thank you anyway 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Warning when using login logo’ is closed to new replies.