Support » Plugin: BP Profile Search » Warning when trying to display the filters

  • Resolved Gilles

    (@alizesonline)


    Hi,

    I am experiencing warnings on a customer’s website. It affects the display of the list of the filters, which is located above the filter form, which keeps working perfectly fine.

    I am getting a list of warnings (one per filter) :

    Warning: implode(): Invalid arguments passed in /my-website.abc/wp-content/plugins/bp-profile-search/templates/members/bps-filters.php on line 73
    
    Warning: count(): Parameter must be an array or an object that implements Countable in /my-website.abc/wp-content/plugins/bp-profile-search/templates/members/bps-filters.php on line 75

    The website is running BuddyPress 7.2.1, BP Profile Search 5.4 and a Divi Child Theme. I am using a custom search form.

    Any idea of the origin of the issue?

    Thank you for your help. best regards.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Andrea Tarantini

    (@dontdream)

    Hi Gilles,

    Until this problem is fixed, you could roll back to the previous version of BP Profile Search, using WP Rollback.

    My first question is, what type are the four profile fields in your search form (Checkboxes, Drop Down Select Box, …)?

    Thread Starter Gilles

    (@alizesonline)

    Hi Andrea,
    Sorry for the late reply.
    There are 4 dropdown fields.
    I see there Buddypress got updated last night to 7.3.0. The issue is still occuring.
    I will manage to revert to a previous version of your plugin today.
    Keep me posted if you need anything to help figuring out the reason of the issue.

    Plugin Author Andrea Tarantini

    (@dontdream)

    Hi Gilles,

    Sorry my question wasn’t clear. I see your search fields are 4 dropdowns, but what’s the type of those 4 profile fields? I’d say the first three are Checkboxes, while the last one is a Multi Select Box.

    Can you confirm?

    Thread Starter Gilles

    (@alizesonline)

    Hi Andrea,

    Sorry, you are right, I did not understand your question properly!

    The 1st field (interest) is Checkboxes
    The 2nd field (category) is Checkboxes
    The 3rd field (country) is Checkboxes
    The 4th field (county) is Multi Select List

    Best regards

    Edit: for your information, I successfully reverted to 5.3.4 from a backup. No more issue.

    • This reply was modified 1 year, 7 months ago by Gilles.
    Plugin Author Andrea Tarantini

    (@dontdream)

    Thank you Gilles,

    I’m going to fix this bug and I’ll release a new version in a few days.

    I’ll keep you informed!

    Thread Starter Gilles

    (@alizesonline)

    Thank you very much Andrea.
    Let me know if I can help performing any test.

    Plugin Author Andrea Tarantini

    (@dontdream)

    Hello Gilles,

    BP Profile Search 5.4.1 is ready.

    It should fix the bug you reported, but it requires a small change in your search form, i.e. replace name="field_37_match_all" with name="field_37_match_single".

    The same with name="field_19_match_all", name="field_10_match_all", and name="field_18_match_all".

    Please let me know if it works for you!

    Plugin Author Andrea Tarantini

    (@dontdream)

    Hi Gilles,

    I forgot to mention that you can simply modify your search form, using the new ‘match single’ search mode instead of the current ‘match all’.

    Thread Starter Gilles

    (@alizesonline)

    Hi Andrea,

    I am awfully sorry. I did not get any warning for your reply. As rolling back to the previous version of the plugin did the trick, I forgot to keep an eye on the thread.

    So yes, that worked for me. I just updated the plugin with the version 5.4.2 and I set every file of the search form to “match single”. And It’s all good.

    So I think we can close this topic.

    Thank you so much for your very quick and efficient help.

    Plugin Author Andrea Tarantini

    (@dontdream)

    You are welcome! Glad to hear the problem is solved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Warning when trying to display the filters’ is closed to new replies.