Support » Plugin: Plugins List » Warning upon activating plugin

  • Resolved craigmbooth

    (@craigmbooth)


    First up, I like this plugin a lot. IT does precisely what I wanted with a minimum of overhead. I just have one little thing to report. When I first activated the plugin in WP3.5.1 I got a notice at the top of every screen:

    Notice: Use of undefined constant APL_DEFAULT_PLUGIN_FORMAT - assumed 'APL_DEFAULT_PLUGIN_FORMAT' in /home/virtual/site154/fst/var/www/craigmbooth/wp-content/plugins/plugins-list/plugins-list.php on line 22

    Line 22 of plugins-list.php should read:

    define('APL_DEFAULT_PLUGIN_FORMAT' ....

    http://wordpress.org/extend/plugins/plugins-list/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Artiss

    (@dartiss)

    Thanks for letting me know – I’ll fix it in the next release.

    Can I assume it only appeared at first and the error has now gone?

    David.

    It appeared at the top of every single page in the admin panel. Making the change I mentioned in the first post (adding quotation marks around the first argument of define() on L22 of plugins-list.php) made the warning disappear immediately.

    I’m not a PHP expert, but maybe the PHP install on my server was set up to be very aggressive with reporting warnings, it didn’t affect the operation of the plugin itself (as the notice says, PHP assumed we meant for the quotes to be there and corrected it), it was just an annoying message.

    Plugin Author David Artiss

    (@dartiss)

    The latest release should fix the errors.

    David.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Warning upon activating plugin’ is closed to new replies.