Support » Plugin: Next Level Cache » Warning: The number of prunes is high.

  • Bryan

    (@weeklykorea)



    Thank you for great plugin.

    I’ve used it for 1 day. And there is an message(below) in the admin dashboard.

    Message: Warning: The number of prunes is high.

    I don’t know the exact meaning but something wrong..

    Could you tell the meaning or solution of the warning?

    Kindly Regards
    Junseok

    https://wordpress.org/plugins/next-level-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Is it possible to bump up the amount of cached queries. i’m currently running it on menulane.com.au which is about 400 listings of place to eat. There is a daily/total counter which is white listed but it seems the cache is just not big enough and is always being pruned when it was doing an awesome job.

    Next job for me is to look into gator-cache and see if i can have minor dynamic content on the page while keeping the rest cached.

    Plugin Author Jason

    (@verysimple)

    Yea I wanted to put in a setting for the plugin but that would require a DB query in order to read the plugin settings! It’s kinda a chicken/egg situation with DB caching on WordPress, but I’m learning more about it.

    The number of prunes refers to when the cache grows larger than the configured “max” size and so the plugin has to empty out some of the values from the cache in order to make room for more. The way NLC works is that it clears out the oldest 1/2 of items.

    If you edit the db.php file you’ll see there are various settings at the top of the script, including the $MAX_CACHE_SIZE which is set to 1000 (1Mb).

    I think it would be safe to bump that up higher, there is some point at which it would probably start to not be effective anymore if the cache is too big, but I don’t know exactly what that number is. I think it could go up to 5000 without too much problem but it’s something that should be tested.

    If you revised your error logs in server says:
    Got a packet bigger than ‘max_allowed_packet’ bytes

    This prune a high number.

    You must too change this in your configuration server.

    Configure the server

    We modify the MySQL configuration file , in the case of Windows systems, the my.ini file in the folder where we have installed the server . For * nix systems , the file /etc/my.cnf .
    In both cases we add / modify the max_allowed_packet parameter that is in the [ mysqld ], for example , to put a 32M or 16M

    max_allowed_packet=32M

    Abd after restarst MySQL server.
    /etc/init.d/mysqld restart

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Warning: The number of prunes is high.’ is closed to new replies.