Support » Plugin: Give - Donation Plugin and Fundraising Platform » Warning: session_start(): Cannot find save handler ‘memcache’

  • Resolved djpeanut

    (@djpeanut)


    I love this plugin in so many ways, except for the fact that it spits out the following PHP warning before any HTTP output:

    Warning: session_start(): Cannot find save handler 'memcache' - session startup failed in /home/tomsbike/sites/transcaucasian.com/wp-content/plugins/give/includes/class-give-session.php on line 367

    Has this been reported before? Any idea what the fix might be? I’m on cPanel shared hosting.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi there,

    This is the first I’ve seen of this error. Can you provide us with your system info? Go to “Donations > Settings > System Info” I think this might be related to your environment.

    Also, what host are you on? Occassionally hosts do strange things with PHP Sessions.

    Thanks!

    Plugin Author Devin Walker

    (@dlocc)

    Hey @djpeanut – We’re glad you love our plugin, that’s always good to hear! 🙂 I haven’t seen that particular PHP warning reported as of yet. Doing a quick Google search on it brings up some server specific settings that may need to be updated on your end. In fact, PHP warnings shouldn’t display on a live site but that’s besides the point. It sounds like there’s an issue on your server running PHP sessions.

    Try adding define( 'GIVE_USE_PHP_SESSIONS', false ); to your wp-config.php file within the root WP directory. Then run a few test donations to ensure everything is working properly and the warning no longer displays.

    Let me know how that goes!

    djpeanut

    (@djpeanut)

    Hi Matt,

    Here’s the output of the system info:

    ### Begin System Info ###
    
    -- Site Info
    
    Site URL:                 http://transcaucasian.com
    Home URL:                 http://transcaucasian.com
    Multisite:                No
    
    -- Hosting Provider
    
    Host:                     DBH: localhost, SRV: transcaucasian.com
    
    -- User Browser
    
    Platform:                 Apple 
    Browser Name:             Chrome  
    Browser Version:          55.0.2883.95 
    User Agent String:        Mozilla/5.0 (Macintosh; Intel Ma 
    			  c OS X 10_12_2) AppleWebKit/537.
                              36 (KHTML, like Gecko) Chrome/55
                              .0.2883.95 Safari/537.36
                              
    -- WordPress Configuration
    
    Version:                  4.7.1
    Language:                 en_US
    Permalink Structure:      /%year%/%monthnum%/%day%/%postname%/
    Active Theme:             Themify Ultra 1.6.3
    Show On Front:            page
    Page On Front:            Home (#1157)
    Page For Posts:           Blog (#7)
    Remote Post:              wp_remote_post() works
    Table Prefix:             Length: 5   Status: Acceptable
    Admin AJAX:               Accessible
    WP_DEBUG:                 Disabled
    Memory Limit:             40M
    Registered Post Stati:    publish, future, draft, pending, private, trash, auto-draft, inherit, refunded, failed, revoked, cancelled, abandoned, spam
    
    -- Give Configuration
    
    Version:                  1.7.2
    Upgraded From:            1.7.2
    Test Mode:                Disabled
    Currency Code:            GBP
    Currency Position:        before
    Decimal Separator:        .
    Thousands Separator:      ,
    
    -- Give Page Configuration
    
    Success Page:             http://transcaucasian.com/donation-confirmation/
    Failure Page:             http://transcaucasian.com/donation-failed/
    Give Forms Slug:           /donations
    
    -- Give Gateway Configuration
    
    Enabled Gateways:         PayPal Standard
    Default Gateway:          PayPal Standard
    
    -- Must-Use Plugins
    
    -- WordPress Active Plugins
    
    Akismet: 3.2
    Fetch Tweets: 2.6.2
    Give - Donation Plugin: 1.7.2
    Jetpack by WordPress.com: 4.4.2
    Regenerate Thumbnails: 2.2.6
    UpdraftPlus - Backup/Restore: 1.12.30
    Wordfence Security: 6.2.10
    WP Geo: 3.4
    WP Maintenance Mode: 2.0.9
    Yoast SEO: 4.0.2
    
    -- WordPress Inactive Plugins
    
    -- Webserver Configuration
    
    PHP Version:              5.4.25
    MySQL Version:            5.5.52
    Webserver Info:           Apache
    
    -- PHP Configuration
    
    Safe Mode:                Disabled
    Memory Limit:             256M
    Upload Max Size:          64M
    Post Max Size:            64M
    Upload Max Filesize:      64M
    Time Limit:               90
    Max Input Vars:           5000
    URL-aware fopen:          On (1)
    Display Errors:           On (1)
    
    -- PHP Extensions
    
    cURL:                     Supported
    cURL Version:             7.24.0
    zlib:                     Supported
    GD:                       Supported
    fsockopen:                Supported
    SOAP Client:              Installed
    Suhosin:                  Not Installed
    DOM:                      Installed
    MBString:                 Installed
    
    -- Session Configuration
    
    Give Use Sessions:        Enabled
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /tmp
    Use Cookies:              On
    Use Only Cookies:         On
    
    ### End System Info ###

    I’m on shared cPanel hosting with Vidahost.com.

    Thank you in advance for any suggestions!

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    HI @djpeanut did you try implementing the change the Devin suggested? Let us know how that goes.

    Hi Matt,

    I didn’t try Devin’s change but I did spot a suspicious looking php.ini file in my WP root that I didn’t recognise. On opening it I spotted the following lines:

    [Session]
    session.save_handler = memcache
    session.save_path = "tcp://10.168.1.55:11211?persistent=1&weight=1&timeout=1&retry_interval=15"

    This looked like an attempted exploit and the possible cause of the issue. Deleting said file resolved the problem.

    Very odd!

    Plugin Author Devin Walker

    (@dlocc)

    Thanks for the follow up with your solution!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.