Support » Plugins and Hacks » [Resolved] Warning seatt events on wordpress 3.5

[Resolved] Warning seatt events on wordpress 3.5

  • Hi
    i would like to know i can i resolve a problem.
    I’ve installed seatt events version 1.2.6 on wordpress 3.5 and i get this error:

    Warning: Missing argument 2 for wpdb::prepare(), called in …./wp-content/plugins/simple-event-attendance/simple_events_admin.php on line 48 and defined in …../wp-includes/wp-db.php on line 990

    How can i change line 48 to resolve this problem?

    Thank you very much


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Dave


    WordPress 3.5 changed how wpdb::prepare functioned, but this was fixed in seatt 1.2.7 – if you upgrade to the latest version (updated in december) it should fix that error.

    is there a way to change the code without upgrading?
    I know that there is a newest version but i would like to not upgrading
    Thank you very much

    Plugin Author Dave


    The newest version fixes some other problems too, but if you really don’t want to upgrade then you can change line 48 to:

    $attendees = $wpdb->get_var($wpdb->prepare("SELECT COUNT(id) FROM ".$wpdb->prefix."seatt_attendees WHERE event_id = %d", $event->id));

    Thank you!!
    I will try this later and i will tell you

    Thank you

    It works!!!
    Thank you very much dave

    Plugin Author Dave


    No problems, feel free to start a new thread if you have any other questions!

    If you’ve got the time I’d appreciate a review, but don’t worry if not 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Warning seatt events on wordpress 3.5’ is closed to new replies.