WordPress.org

Support

Support » How-To and Troubleshooting » Problem loading website

Problem loading website

  • Please bear with me, as I am not great on WordPress, but am trying to diligently learn as I go.

    I wanted to download a new theme, but before I did that, WordPress suggested I backup my files and download the latest version, 3.5.1

    I tried to do this, and everything got messed up. Then I read that you shouldn’t skip more than 2 upgrades (I was using 3.4.1 before. So, I tried to delete some files and go back to 3.4.2

    I downloaded the 3.4.2 file onto my FTP server, but now I get the following error message when I try to go on my site:

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/a7847908/public_html/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a7847908/public_html/index.php on line 17

    Then, I wanted to see what would happen when I try to go onto my site’s /wp-admin area. This is the error message I received there:

    Warning: require_once(/home/a7847908/public_html/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/a7847908/public_html/wp-admin/admin.php on line 30

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/a7847908/public_html/wp-load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a7847908/public_html/wp-admin/admin.php on line 30

    Can anyone help explain this to me and how I can fix it? Also, I tried to restore the backup I had before I did any of this, but the file keeps downloading as an sl file instead of an sl.qz file, and therefore my web host server won’t accept it.

    I hope I’ve given enough information to get some help? I appreciate it!

Viewing 7 replies - 1 through 7 (of 7 total)
  • I tried to tinker around with it some more, and I seemed to have fix part of the header problem, but now I’m receiving this error:

    Warning: require_once(/home/a7847908/public_html/wp-settings.php) [function.require-once]: failed to open stream: No such file or directory in /home/a7847908/public_html/index.php on line 90

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/a7847908/public_html/wp-settings.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a7847908/public_html/index.php on line 90

    Any ideas?

    I’ve been experiencing a similar problem, except my website will only load at home, and no where else. as in it just won’t load! WP really needs to fix these problems

    WPyogi

    @wpyogi

    Forum Moderator

    @caitjank – you have your own thread – http://wordpress.org/support/topic/problem-loading-website?replies=5 Please don’t jump into other threads as it really confuses things on these forums.

    @adashofsarah – do you have a backup of your site and database?

    @WPyogi – I believed I had backed up my site. It even has 2 files available for download of it. one is an .sl file, and the other is a .tar file, I believe. However, when I do these and try to use the “1-click database restore” feature on my host, it doesn’t accept the files. Sorry, does this make sense at all? I’m new when it comes to working with this stuff!

    WPyogi

    @wpyogi

    Forum Moderator

    Hmm, where is your site hosted? Have you asked if they can restore your site?

    Unfortunately, I went the cheap/free route, and have been using 000webhost as my host. I’ve been meaning to pay and switch over to a site like godaddy, but haven’t had the time to do so lately.

    I just sent them a ticket to help me restore it to the last back up. It says I should get a reply within 24 hours. In the mean time, is there anything else you can suggest I do to try and get my site up-and-running? I would like to eventually switch to a newer version of WordPress (as most of the latest plugins/themes require it), but the automatic update doesn’t seem to work for me.

    They still have yet to reply. Any suggestions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problem loading website’ is closed to new replies.