Support » Fixing WordPress » Warning: require_once wp.load

  • Resolved alexjmann

    (@alexjmann)


    My site went from working to not working, literally overnight. I woke up in the morning and tried to log on to my dashboard, and received this error:

    Warning: require_once(/home/alexjmann/alexjmann.com/wp-config.php) [function.require-once]: failed to open stream: Permission denied in /home/alexjmann/alexjmann.com/wp-load.php on line 27

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/alexjmann/alexjmann.com/wp-config.php’ (include_path=’.:/usr/local/php5/lib/php:/usr/local/lib/php’) in /home/alexjmann/alexjmann.com/wp-load.php on line 27

    I’ve made major edits to the CSS, so I’d like to avoid replacing all of the files. Help would be appreciated.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I received the same exact error! Same thing — worked last night, and doesn’t work today. I can’t even log into the back end… all avenues lead to the error.

    I’m reinstalling just the default wp-load file. We’ll see if that works. I’ll let you know.

    I reinstalled the default wp-load file, and nothing changed. Still getting the same error. Would appreciate any guidance on this.

    This happened to me overnight as well. Is it an odd coincidence, or has someone taken advantage of new vulnerability? Have we been hacked?

    The site I’m working with is hosted on Dreamhost. Anyone else?

    I’m Dreamhost as well. I contacted them a few minutes ago. This is an odd coincidence indeed.

    If we are all on Dreamhost, it could be a problem with their apache settings or php library or how they run php as cgi.

    The paths in my error have the same structure as alexjmann, both to my files and the php library. That also suggests we might be on the same host.

    Then it’s true. Everyone contact Dreamhost ASAP. If anyone at WordPress has a phone contact, a call would be very much appreciated.

    Is your file server named Riddler? MySQL server Phillip? (Click account status toward the top right in your Dreamhost panel.)

    If anyone else is having trouble, make a note here and give dreamhost a link to this thread when you contact support.

    Riddler; yes. MySQL is not Phillip, it is towelie.

    Please let me know if you make any progress on this. I will forward Dreamhost this thread.

    I’m resolved. The issue was on Dreamhost’s end.

    Happened to me as well (also on Dreamhost). My site is still down.

    Not fixed for me yet. Did they tell you what it was? …So I can tell them to look for the same thing?

    Thanks for the teamwork…

    Dreamhost says: “Sorry for the trouble. The issue was One-Click related. A push out inadvertently changed the permissions on wp-config.php. Running chmod 644 wp-config.php will fix it. We’re aggressively working on correcting the issue now. Thanks for your patience.”

    You can fix it yourself by changing the file permissions on wp-config.php to 644. But they’ll do it for you soon enough.

    Scary that their one-click is making changes to our sites with zero-clicks.

    forgive my rookie-ims but how do you change those permissions exactly?

    I was not given an explanation by Dreamhost. They just emailed me and told me it was fixed.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Warning: require_once wp.load’ is closed to new replies.