Support » Themes and Templates » Warning: require_once – got a warning after installing a theme

  • I got this warning after having installed the theme “canyon”:

    Warning: require_once(/home/www/floejene.mortenvium.dk/wp-content/themes/canyon/lib/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/floejene.mortenvium.dk/wp-content/themes/canyon/functions.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/www/floejene.mortenvium.dk/wp-content/themes/canyon/lib/init.php’ (include_path=’.:/php/includes:/usr/share/php’) in /home/www/floejene.mortenvium.dk/wp-content/themes/canyon/functions.php on line 3

    It surprised me, as the theme seems to be a much used one.
    Does anyone know what could have caused this warning, and what i can do to make it go away? The entire server is down. Help would be much appreciated 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Where did you get the theme from? I would start by contacting the company you got the theme from. They would know more about it than anyone.

    If you got it from off the internet somewhere, there is a good chance you installed a theme with potentially malicious code in it. If you can FTP to your account, I would delete it as soon as possible. If you do not have FTP access, contact your host and see if they can do anything.

    Are you running this on a localhost?

    It is downloaded on wordpress.org.
    I can’t FTP to my account.
    Thank you, I guess I’ll try that 🙂

    Im not sure if it’s localhost?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Warning: require_once – got a warning after installing a theme’ is closed to new replies.