Support » Fixing WordPress » Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in

  • While writing posts and saving as drafts, this suddenly appeared on my manage posts and pages screens, as well as on the home page, above the wordpress blog itself. (http://www.pinkraygun.com)

    Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /path/path/path/wp-includes/classes.php on line 95

    And the same at line 96

    This happened a few days ago, and simply updating my permalinks options seemed to work. Today, not so much.

    I’ve added no new plugins, or done any sort of PHP mucking around.

    Anyone have any idea what’s going on and how I can fix this?

    Thanks in advance,

    John

Viewing 8 replies - 1 through 8 (of 8 total)
  • Additional information – this error code only appears in the manage posts and manage pages windows, and on the home page of the blog. Opening a post into it’s own window shows none of this error code. Please, anyone know how I can fix this?

    I hate to bump this up, but I’m getting the exact same error. Only on certain pages mentioned above.

    I’ve not installed anything, or modified any code. It was working fine just a few hours ago. I come in, check the site, and I get..

    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /path/path/path/markw/wp-includes/classes.php on line 95

    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /path/path/path/markw/wp-includes/classes.php on line 96

    Line 95: if (preg_match(“!^$match!”, $request_match, $matches) ||

    Line 96: preg_match(“!^$match!”, urldecode($request_match), $matches)) {

    The rest of the code looks give.

    I’ve deactivated all my plugins as well. Hope I can get some help, I’m at a lose.

    I do not hate to bumb this because I too am now receiving this exact same error message, which also seems to appear on my 404 error page.

    Anyone know why this is happening?

    I get this error message too when saving post as drafts,and updating permalinks as intergalacticlaw said can resolved this problem
    I’m using the lastest version of wordpress 2.22

    nebulousbee

    (@nebulousbee)

    I just installed WordPress 2.2 today.

    I just started getting this exact same error message too. All was well one minute, then I think right after I edited a post, boom.

    After reading the comments above, I changed my Permalinks setting back from “Custom” – ?space=123 – to the Default setting and the errors stopped occurring. I can go back and forth with that one setting to see the errors/resolve them so I’m sure, in my case at least, this is where the fault is.

    Anyone else find this solution workable in the long run?

    i also need help for this!
    my wordpress 2.3.2 was working ok.. but i changed a plugin in something (301 redirections) and it started to show that message!
    i removed, deactivated the plugin.. and nothing!

    I found changing the permalink to the default removes the error. My blog is broken too but I haven’t made it public yet.

    I fixed this issue so hopefully this will help those who follow…

    In the control panel change your Permalink from…
    /?%postname%

    …to…
    /%postname%

    So essentially remove the question mark (which represents an HTTP query).

    To support an HTTP query either the classes.php file will need an update to it’s regex to add support or maybe there is already an existing method to achieve this though I’ve only been messing with WordPress for half a week.

    Good luck!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in’ is closed to new replies.