Support » Plugin: Google XML Sitemaps » Warning: PHP Deprecated

  • Have just moved to PHP 7 on server and have a lot of warnings:

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorStatus has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 18

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorPage has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 228

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorXmlEntry has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 364

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorPrioProviderBase has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 390

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorPrioByCountProvider has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 464

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorPrioByAverageProvider has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 530

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGeneratorPrioByPopularityContestProvider has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 611

    PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; GoogleSitemapGenerator has a deprecated constructor in \wp-content\plugins\google-sitemap-generator\sitemap-core.php on line 695

    • This topic was modified 4 months, 2 weeks ago by  Malae.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Did this php issue get resolved?

    @itsgotime,

    I am presently running version 4.0.9 on PHP 7.1 and am no longer getting the above warnings. It is possible that I was using an earlier version of the plugin on PHP 7, when I reported the above warnings.

    I am still getting the above warnings from a site on a server running PHP 7.0.10, but not one another site on a server running 7.1.10. I cannot explain this.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.