Support » Plugin: Jetpack by WordPress.com » Warning Notice: Undefined index: options-general.php

  • Resolved avgrafica

    (@avgrafica)


    Hello
    After the last update a notice appeared on the top of the page in the publisher backend:

    Notice: Undefined index: options-general.php in /home/cpltwssn/public_html/wp-content/plugins/jetpack/_inc/lib/class.jetpack-keyring-service-helper.php on line 56

    Warning: Cannot modify header information – headers already sent by (output started at /home/cpltwssn/public_html/wp-content/plugins/jetpack/_inc/lib/class.jetpack-keyring-service-helper.php:56) in /home/cpltwssn/public_html/wp-admin/includes/misc.php on line 1196

    I have already tried to disable the component and reinstall it but the error message persists when Jetpack is active again.

    I also checked the files involved to make sure that there are no blank spaces before or after the <? php and?> tags. I have not detected any, what can be the cause of the message?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Thanks for the report!

    Could you let me know what other plugins you run on this site? Do you use any plugins that may customize the admin menu, by any chance?

    avgrafica

    (@avgrafica)

    Hello Thanks for the reply.
    In the admin area I’m using the User Role Editor plugin for managing the acl.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Thanks for letting me know. Could you temporarily deactivate that plugin? I’d like to confirm that it is indeed the source of the conflict on your site.

    On our end, we’re working on a patch to work around this. You can follow our progress here:
    https://github.com/Automattic/jetpack/pull/13971

    avgrafica

    (@avgrafica)

    I tried disabling the plugin after resetting the acl but the warning continues to be present.

    Thanks for the reply, I will keep track of future developments.

    • This reply was modified 1 month ago by avgrafica.
    avgrafica

    (@avgrafica)

    Ok i tried the Testing instructions: and the popup seem open correctly lead me to Google account

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Thanks for letting me know. If the patch works for you, we’ll aim to include it in the next version of Jetpack.

    Sorry for the trouble!

    avgrafica

    (@avgrafica)

    I apologize, there has been a misunderstanding.
    I meant that the google link window is activated correctly, but this did not resolve the warnings displayed by publishers and authors.

    I am attaching the screens of the problem and the connected area

    Screen1
    Screen2

    This is a list of active plugins, I hope it can be useful to offer a better understanding of the problem also because it is blocking in the search within the administrative area of ​​the articles of the users involved.

    AddToAny Share Buttons
    Akismet Anti-Spam
    Better Notifications for WP
    Cloudflare
    Column Shortcodes
    Contact Form 7
    Contact Widgets
    Cookie Notice
    Disable Embeds
    Google Analytics for WordPress by MonsterInsights
    Greg’s Threaded Comment Numbering
    I Recommend This
    Jetpack by WordPress.com
    MailPoet 2
    Markup (JSON-LD) structured in schema.org
    Social Icons Widget by WPZOOM
    Taxonomy List Widget
    TinyMCE Advanced
    User Role Editor
    Widget Options
    Yoast SEO

    • This reply was modified 1 month ago by avgrafica.
    avgrafica

    (@avgrafica)

    For now i disabled the WP_DEBUG_DISPLAY to let the authors work without warning

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    If you feel comfortable making changes to PHP files, could you try to apply the patch from the link I posted earlier, and let me know if that helps?

    Ok I had not applied the php modification.
    With a bit of attention I replaced line 56 with the indicated code.

    I have re-enabled screen debugging and the solution seems to work, I no longer see security warnings in the author account.

    Thank you very much!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.