• Resolved mev

    (@mev)


    I accepted an automatic update to latest WordPress Mobile Pack (3.0) and now have the following messages appearing on my blog:

    Warning: in_array() expects parameter 2 to be array, string given in /homepages/19/d152872219/htdocs/scc2ush/wp-content/plugins/wordpress-mobile-pack/frontend/sections/show-rel.php on line 49

    Warning: array_intersect(): Argument #2 is not an array in /homepages/19/d152872219/htdocs/scc2ush/wp-content/plugins/wordpress-mobile-pack/frontend/sections/show-rel.php on line 54

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor anghelalexandra

    (@anghelalexandra)

    Hi there,

    Can you please tell me what plugin version you had before upgrading to 3.0?

    How can I find out the preceding version of a plugin?

    I first installed the WordPress Mobile Pack when I set up the blog (~2015). I have accepted automatic updates that were made available including this latest one.

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    Hi again,

    I asked about the plugin version because the way that we save the plugin settings in the database has changed apx. 1 year ago. It’s possible that your settings are currently saved in the old format.

    If you go to the WP Mobile Pack admin > “Content” tab and deactivate / re-activate a page, do you still get the same error?

    If I deactivate everything, no errors.

    Trying to deactivate a page, it seems to wait forever with a please wait message.

    I haven’t done many customizations so may delete the entire plugin and then reinstall.

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    Ok, that is a good idea. Please make sure to delete the plugin from the WordPress admin, so it also deletes the options saved in the database. Let me know if reinstalling the plugin solves the warning message.

    I had the same problem pop up on on my site. Been using the plugin for a long time now. Adding

    ini_set(‘display_errors’,0);

    to my wp-config.php file made the error invisible, but what’s wrong with the plugin?

    Plugin Contributor anghelalexandra

    (@anghelalexandra)

    @jim0266

    Can you try the following fix?

    Please edit the wp-content/plugins/wordpress-mobile-pack/inc/class-wmp-options.php file and replace its contents with this: https://raw.githubusercontent.com/appticles/wordpress-mobile-pack/9620e7e31ce50b78ea503ba22d3c3323cb1fb094/inc/class-wmp-options.php

    This is the file version before the last release.

    Let me know if this fixes the warnings so we can revert to this version in the next release.

    Thanks, replacing the old code solved the problem as well.

    • This reply was modified 3 years, 2 months ago by jim0266.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Warning messages with latest Mobile Pack’ is closed to new replies.