Support » How-To and Troubleshooting » [Resolved] Warning message when saving a draft post.

[Resolved] Warning message when saving a draft post.

  • I’m running wordpress 2.02, with a customized kubrick-derivative theme, running only the “admin menu” “database backup” and “akismet” plugins.

    A couple weeks ago, this error started showing up when I tried to save posts (or save edits, basically anything involving the “save” button):

    Warning: Header may not contain more than a single header, new line detected. in /path/to/wordpress/wp-admin/post.php on line 127


    Troubleshooting I’ve done so far: pointing a fresh wordpress at the same database maintains the same problem.

    Pointing the same wordpress install at a fresh database causes the problem to go away.

    I wasn’t sure what was up with that, so I dumped the major tables from the db (posts and comments) and created a fresh db, imported the posts and comments and reconfigured everything else, and the problem went away for about 2 weeks.

    But it just came back. I had already saved the post I was working on several times, and one of the times that error suddenly started. Now it happens at every save.

    All this really does is prevents me from being redirected back to the post editing page, but that in itself is pretty irritating.

    Anyone encountered this before, or have any ideas about it?

    (further information: hosted on dreamhost, running php5.1.2, mysql 5.0.16)


Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m getting the same error, just started after the latest update for me though.

    I’m trying to isolate my plugins and such to see what I can see.

    Also hosted on DH, just FYI.



    In my case I’m guessing it’s related to the PodPress plugin.

    If I deactivate it the problem goes away, then comes back when I turn it back on.

    I’m reporting it to the author.


    yeah, mine wasn’t doing that, I didn’t have any interesting plugins going, and the behavior was erratic.

    During my last hapless flailing at it, I changed my table type from MyISAM to InnoDB, and I haven’t been able to replicate the problem since then. Might just have been myisam failing me… dunno

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Warning message when saving a draft post.’ is closed to new replies.