Support » Plugin: Picasa and Google Plus Express » Warning message has been appeared

  • Resolved ghvst

    (@ghvst)


    Hello,
    my WordPress page which is using the Picasa Express x2 plugin
    has been showing the following message just before the body of a post:

    “Warning: Invalid argument supplied for foreach() in /home/ghvst/www/wordpress/wp-content/plugins/picasa-express-x2/picasa-express-2.php on line 1695”

    I’ve not modify the code of the plugin.
    I wonder if the version 2.2.1 of this plugin is not compatible with WordPress 3.5.1…
    Does anyone have same experience ?

    http://wordpress.org/extend/plugins/picasa-express-x2/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author gjanes

    (@gjanes)

    I am the plugin developer and I’m using WordPress 3.5.1 on PHP 5.3.3 and I have not seen this issue. Could you please provide the [pe2-gallery …] tag that is causing this issue?

    Hi gjanes,

    My webserver provides PHP 5.2.17 . Here is the tag:

    [pe2-gallery]
    [pe2-image src="http://lh6.ggpht.com/-OycNHIGdBF8/UQVOKrc6FaI/AAAAAAAAGo0/UvMRzxw7qxo/s144-c/IMG_3183.JPG" href="https://picasaweb.google.com/105891130731654950448/20130126#5838158437325346210" caption="まだ少し早い梅の蕾。" type="image" alt="IMG_3183.JPG" pe2_single_image_size="w140" pe2_single_video_size="w140" ][/pe2-gallery]

    and THIS LINK will show you the web page.

    Plugin Author gjanes

    (@gjanes)

    I will take a look, should be an easy fix.

    Plugin Author gjanes

    (@gjanes)

    I have updated the “Development version” on the “Developers” tab of the plugin page:

    http://wordpress.org/extend/plugins/picasa-express-x2/developers/

    The “Development version” has a fix for this issue, try it out and let me know if it solves the problem.

    I’ve tried the Dev. version, and saw that the warning message disappeared.
    Thank you.

    But clicking a thumbnail will not open the large image such like the old versions.
    To find the cause, I looked into your code and found some codes:

    // create align vars
    // for caption - align="alignclass" including alignnone also
    // else add alignclass to iclass
    $calign = '';
    $iclass = array();
    if ($pe2_caption) {
    	$calign = 'align="align'.$pe2_img_align.'" ';
    }
    array_push($iclass,'align'.$pe2_img_align);

    I inserted an “else” like below and the large image is now opened successfully:

    if ($pe2_caption) {
    	$calign = 'align="align'.$pe2_img_align.'" ';
    }else{
    	array_push($iclass,'align'.$pe2_img_align);
    }

    This modification works well for me, but is this a good fix?

    Plugin Author gjanes

    (@gjanes)

    I will try to review this soon, and if it works get the fix into a release. Thanks for your patience.

    Plugin Author gjanes

    (@gjanes)

    I’m unable to replicate the problem that you’re having, and I don’t really see how the else is related – I’m guessing the issue is related to something different.

    Could you revert your change (take the else back out) and provide me a link that illustrates the problem so I can see if I can replicate it on my end?

    Here is the link:
    http://ghvst.noob.jp/theme-and-plugin/5981-2

    Before showing the link, I had disabled some of my other plugins such as wp-jquery-lightbox, MO Cache and WP File Cache, Shareaholic, Head Cleaner. But I did’t see any improvement.

    Plugin Author gjanes

    (@gjanes)

    This should be resolved. It appears that the issue you’re having is related to your theme. The css on your theme has all kinds of crazy styles for .alignleft.

    However, I was able to change the video overlay functionality to use native Google+ video overlay functionality, which removed the requirement to have the image using the alignleft class when captions are enabled, so I put in place the else you suggested.

    I think this should resolve your issue.

    I’ve update my site with the version 2.2.3 of your plugin.
    Now I can see my images popping up well by the lightbox plugin.
    Thank you very much for fixing the issue, gjanes.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Warning message has been appeared’ is closed to new replies.