WordPress.org

Forums

BulletProof Security
[resolved] Warning message appears on all site pages (7 posts)

  1. MikeHarrison
    Member
    Posted 1 year ago #

    After my site was moved to a new server, I first updated the server ip address in my Brute Force Login Protection code, and then reactivated Bulletproof mode on the root folder .htaccess file and the wp-admin folder .htaccess file. I then backed up my site's database before updating to WordPress version 3.6.

    Now, the site seems to be perfectly fine with two exceptions: the main (slider) image on the home page does not appear, nor do two other images, each on a separate blog post page. All other images throughout the site appear normally.

    Two warning messages appear at the bottom of each page on the website:

    Warning: Unknown: open(/home/content/76/6863576/tmp/sess_7gdbj72buk91fuofus34rkge20, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
    
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    If I attempt to right-click the home page image to open it in a new window, I receive a 403 Forbidden Error page with this message:

    Warning: session_start() [function.session-start]: open(/home/content/76/6863576/tmp/sess_7gdbj72buk91fuofus34rkge20, O_RDWR) failed: No such file or directory (2) in /home/content/76/6863576/html/wp-content/plugins/bulletproof-security/403.php on line 3

    I get a similar message if I try to open the other two images.

    The mention of Bulletproof security is why I'm posting this in this forum. I don't know what this code is telling me. Can anyone please help me try to figure out what the trouble is? I've posted a similar plea for help in the WordPress 'How-To and Troubleshooting' forum.

    Thanks!

    http://wordpress.org/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Try clicking the AutoMagic buttons again activating Root folder and wp-admin BulletProof Modes.

    If the errors are still occurring...

    These errors indicate a possible PHP Server Configuration problem on this new Server. Please ask your Host about these errors so that they can check things like your php.ini file if you are using one or the Server's php.ini file.

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Oops did not see this additional question:

    ...the main (slider) image on the home page does not appear, nor do two other images, each on a separate blog post page. All other images throughout the site appear normally.

    Check your BPS Security Log and post any log entries that are relevant to the slider plugin and the images on the separate blog post page. The log entries will contain the name of the plugin in the logged error.

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Also I just thought of another possible cause for plugin errors when migrating to a new Server. Some plugins contain paths within configuration files that need to be updated when migrating the site. In this case you moved to another Server, but it is worth a shot to deactivate and activate all plugins again. What this will do is if a plugin contains path configuration info within the plugin's configuration files then these paths will be automatically updated by deactivating and activating that plugin.

  5. MikeHarrison
    Member
    Posted 1 year ago #

    Ah... good thought about the plugin paths. I'll do that now. In the meantime, here are three entries from the error log, one each for the three images that aren't loading.

    >>>>>>>>>>> 403 GET or Other Request Error Logged - August 5, 2013 - 10:03 am <<<<<<<<<<<
    REMOTE_ADDR: 24.38.214.40
    Host Name: ool-1826d628.dyn.optonline.net
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://mike-harrison.com/
    REQUEST_URI: /wp-content/themes/perfectpixel/timthumb.php?src=http://mike-harrison.com/wp-content/uploads/2013/03/CredibleFluentBanner.jpg&w=650&h=300
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/536.29.13 (KHTML, like Gecko) Version/6.0.4 Safari/536.29.13
    
    >>>>>>>>>>> 403 GET or Other Request Error Logged - August 5, 2013 - 10:04 am <<<<<<<<<<<
    REMOTE_ADDR: 24.38.214.40
    Host Name: ool-1826d628.dyn.optonline.net
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://mike-harrison.com/mikes-blog/
    REQUEST_URI: /wp-content/themes/perfectpixel/timthumb.php?src=http://mike-harrison.com/wp-content/uploads/2012/07/WABC-Transmitter.jpg&w=680
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/536.29.13 (KHTML, like Gecko) Version/6.0.4 Safari/536.29.13
    
    >>>>>>>>>>> 403 GET or Other Request Error Logged - August 5, 2013 - 10:04 am <<<<<<<<<<<
    REMOTE_ADDR: 24.38.214.40
    Host Name: ool-1826d628.dyn.optonline.net
    SERVER_PROTOCOL: HTTP/1.1
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER: http://mike-harrison.com/mikes-blog/
    REQUEST_URI: /wp-content/themes/perfectpixel/timthumb.php?src=http://mike-harrison.com/wp-content/uploads/2012/04/Thank-You.jpg&w=680
    QUERY_STRING:
    HTTP_USER_AGENT: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/536.29.13 (KHTML, like Gecko) Version/6.0.4 Safari/536.29.13
  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    For simulated timthumb RFI hacking attempt Theme links like these you can create a skip/bypass rule. See the Forum link below for the solution. Use the Custom Code CUSTOM CODE PLUGIN FIXES: option.

    http://forum.ait-pro.com/forums/topic/images-not-displaying-after-bulletproof-security-free-plugin-was-enabled-and-configured/

  7. MikeHarrison
    Member
    Posted 1 year ago #

    Genius! The images now load.

    Thank you immensely.

    The two original warnings I posted still appear on the bottom of every page, but they must not have had anything to do with the images. I took your advice and forwarded those warnings to my hosting company, asking that they look into the php.ini file, as you suggested....

    Actually, after typing the previous paragraph, I returned to my site and noticed that the two warnings now no longer appear. So maybe the hosting company found and fixed the problem, or... I don't know, but they're gone.

    Thanks so much for your help, terrific knowledge and speedy replies!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.