Support » Fixing WordPress » Warning message and site not loading

  • Resolved Baden95

    (@baden95)


    Hi there,

    I can’t seem to access my site anymore. Whenever I try to access it, this message appears instead of my site:

    Warning: require(/home/bybamax/public_html/wp-includes/compat.php) [function.require]: failed to open stream: Permission denied in /home/bybamax/public_html/wp-settings.php on line 246

    This all seemed to happen when I added another domain to my hosting account. Any ideas about what’s going on? This is my URL if you wanna check it out: http://suave-man.com

    I’d really appreciate any help I can get

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you changed your directory structure under public_html? Maybe some folders where removed during the process of adding another domain. And have you verified the permissions for the file in question? Try making it readable to your webserver.

    Hi,

    Assign 755 permissions to your wordpress folders and files. Also check with upgrading the wordpress version as well as disabling the plugins.

    Thanks,

    Shane G.

    Awesome thanks Shane, that worked and I’m back online. I haven’t disabled any of my plugins yet and I’m already running 2.8.6. Do you still recommend I do those 2 things even though my sites running again?

    I’m not sure what happened there, do you have any ideas guys? I’m assuming something went wrong when I added the new domain to my hosting account, but I’m not sure, or where in the process it would’ve happened.

    To answer your questions Christian; No I never changed my directory structure. I tried verifying permissions for that file, but I was denied permission to access files.

    Hopefully it won’t happen again as I’m planning on adding more domains to that same account.

    Anyway, thanks again guys, I really appreciate your help

    Baden

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Warning message and site not loading’ is closed to new replies.