Support » Alpha/Beta » [Resolved] Warning makepot.php Revision 25726: /trunk/tools/i18n

[Resolved] Warning makepot.php Revision 25726: /trunk/tools/i18n

  • Hi, when i try to use the new makepot.php from http://develop.svn.wordpress.org/trunk/tools/i18n/ i got a php error :

    the php file is looking for the pomo folfer in C:\Server\sitename\wp-content/src/wp-includes/pomo/po.php

    Wasn’t it supposed to be in


    For info i’m on windows

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Ipstenu (Mika Epstein)


    Is this still happening on Beta2?

    I’ll check it out and let you know but it’s not coming from WordPress but something coded in the makepot.php file so i guess it will not change anything

    Moderator Samuel Wood (Otto)


    If you examine the structure of the new develop.svn layout, then the WordPress source is now indeed inside a /src folder.


    So you need to check out the whole trunk to use the new tools properly. This may mean altering where you have your server looking for the wp files if you’re using it as a “live” site.

    Thanks Otto for the hint about the svn structure.
    I’m on a WP live install indeed, so no src folder.
    I was a bit confused cause the previous makepot.php was working on my install, that’s why without any problem.

    Now i can fix it. And i’ll check all the i18n folder content then cause i’m sure you used the same structure 😉

    Thanks, the subject is now closed

    I had the same issue, perhaps some kind of notice could be added to the i18n directory? A small readme to notify the user that i18n tools have a dependency in WordPress itself.

    Btw I find this dependency on core WordPress files for a supposedly standalone i18n tools rather strange and I’ve opened a ticket about it, see https://core.trac.wordpress.org/ticket/27696

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Warning makepot.php Revision 25726: /trunk/tools/i18n’ is closed to new replies.