Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Warning: Invalid argument supplied for foreach() after plugin upgrade on v.2

  • Resolved B_Dark


    I got this msg :

    Warning: Invalid argument supplied for foreach() in /home/****/public_html/wp-includes/query.php on line 1702

    after upgrade you plugin on my multisite , i tried to make update on /wp-admin/network/admin.php?page=nextgen-gallery

    And i got this msg too:

    Warning: Cannot modify header information – headers already sent by (output started at /home/*****/public_html/wp-includes/query.php:1702) in /home/*****/public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/frame_communication/class.frame_event_publisher.php on line 67

    how can i fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author photocrati


    Multi-site is a huge priority for us. Because legacy versions of NextGEN (1.9.x) were only partially compatible, we were not able to finish completing the code for full compatibility in v2.0 for multi-site but we do have that on our agenda for one of the next upgrades.


    Thnx for the fast response . i roll back to 1.9.13. waiting the new update for multisite 🙂

    Plugin Author photocrati


    @b_dark – No problem. We hope to have that out soon! If you need help with how to roll back a version, we have a help doc here:

    Hope that helps!

    thanks a lot from my side as well… I upgraded to 2.0 with a database backup but (of course…) having forgotten to backup the server files.
    Got the same error messages as B_Dark. Thanks to your help doc I managed to roll back to 1.9.13 within a few minutes – despite normally being IT-illiterate. Highly appreciated!

    Plugin Author photocrati


    @vimo and @b_dark: While NG isn’t completely mulitsite compatible (Legacy 1.9.x wasn’t either), you should be able to activate on a mutlisite-enabled WordPress instance, and you should be able to use it fine on the main blog. Are you able to do that, or are the errors above preventing activation? If so, that may be a separate issue.


    I’ve got the same problem. After updating to 2.0.0 on a multisite installation, i get the same error message concerning line 1702 in the query php.

    my workaround was to put if ( is_array( $GLOBAL[‘wp-taxonomies’] )) around the foreach loop. But the problem itsself is caused by NG. Could you please fix it. The error message is visible on the frontend and backend…

    We get a lot of trouble with our customer…

    from my side, i activated from main network /wp-admin/network/plugins.php
    and shows me this error

    Plugin Author photocrati


    Thanks for the update and sharing your workaround @netmorix & @b_dark. Please know that we are working rapidly towards multisite compatibility and will hopefully reach a working solution soon. If you’re seeing errors with v2.0, you might consider rolling back to v1.9.13 until we are multisite compatible. See:

    Hope that helps!

    Same error for me on multisite. As you said above, Photocrati, it works on the main site if only activated on main site. But it’s not working on sub sites when activated on them.

    I am glad you said that you are working towards multisite full compatibility because more and more WP web designers build only multisites. That’s my case – If not for immediate multilingual needs, a client might need a sub site anytime. It’s much more convenient to build a multisite from the start rather than converting a single site to a multisite.

    Thanks to the Photocrati team for your attention to this thread,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Warning: Invalid argument supplied for foreach() after plugin upgrade on v.2’ is closed to new replies.