Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Warning: Invalid argument supplied for foreach()

  • Hello, first af all thank you for this amazing plugin!
    When I try to view a “tag” page (as in http://www.mysite.com/tag/tag-name) I get this error:

    Warning: Invalid argument supplied for foreach() in /web/htdocs/www.MYSITE.it/home/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/package.module.nextgen_gallery_display.php on line 1852

    The 1852 line is

    foreach ($display_type->entity_types as $type) {

    1846-1866 lines:

    public function is_compatible($source, $display_type)
        {
            $retval = FALSE;
            if ($source = $this->get($source->name)) {
                // Get the real entity type names for the display type
                $display_type_entity_types = array();
                foreach ($display_type->entity_types as $type) {
                    $result = $this->get_entity_type($type);
                    if ($result) {
                        $display_type_entity_types[] = $result;
                    }
                }
                foreach ($source->returns as $entity_type) {
                    if (in_array($entity_type, $display_type_entity_types, TRUE)) {
                        $retval = TRUE;
                        break;
                    }
                }
            }
            return $retval;
        }

    The error does NOT appear when viewing category pages. How can I fix it?
    Thank you!

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author photocrati

    (@photocrati)

    @rinoadiary – We’re not seeing this issue ourselves, can you provide the actual URL where this is happening versus the generic URL you are using for your example?

    Thanks!

    – Cais.

    Plugin Author photocrati

    (@photocrati)

    @rinoadiary – Are you seeing this if you temporarily switch to a default WordPress Twenty series theme? Also, are you tagging your images; or, are you tagging your posts; or, both?

    Thanks!

    – Cais.

    Are you seeing this if you temporarily switch to a default WordPress Twenty series theme?

    Yes, same error

    Also, are you tagging your images; or, are you tagging your posts; or, both?

    Tags are related to posts only

    Plugin Author photocrati

    (@photocrati)

    @https://profiles.wordpress.org/rinoadiary – I’m not able to reproduce this issue with any theme currently, including the latest default installation of your current theme.

    Have you tried deactivating all of your plugins, clearing your browser cache (and site caches if you are using a caching plugin), then reactivating the NextGEN plugin?

    If this fixes the problem then it was likely one of the deactivated plugins that was causing an issue. Now, retrace your steps activating each plugin and re-checking to see if the problem returns. If it does then that last activated plugin was probably the one. Keep reactivating and in most cases it is also best to keep checking after each plugin, sometimes there may be more than one plugin on a site that will create an issue. If you do find one (or more) plugins causing this problem we would greatly appreciate your feedback on them so the developers may address them as soon as they can.

    If the problem still persists after all of this we would still want to know, even more so, as we will still want to sort out the issue and may need additional details.

    Thanks!

    – Cais.

    Thank you for your tip, the issue seems to be related to the “Download Manager” plugin.

    Plugin Author photocrati

    (@photocrati)

    @rinoadiary – Thanks for the update!

    – Cais.

    Sadly I’m getting no support at all from the download manager author. Thank you for your help tho!

    Plugin Author photocrati

    (@photocrati)

    @rinoadiary – Sorry to read that. Hopefully it is just a problem of bad timing on that author’s part and they will be able to help you soon.

    – Cais.

    I’m not sure where to post my question, but I thought I’d start here. I’m getting this error message while editing my Profile page:

    Warning: Invalid argument supplied for foreach() in
    /home/sahbar5/public_html/wp-content/plugins/ultimate-member/core/um-fields.php
    on line 1991

    I’ve tried deactivating all of my plugins to see if there are conflicts, but nothing has helped. I’ve also tried contacting Ultimate Member (the plugin author), but no answers yet.

    Any ideas??

    Plugin Author photocrati

    (@photocrati)

    @lazormish – Please start your own topic so we can try to help you with your specific issue on your specific site.

    See https://make.wordpress.org/support/handbook/forum-welcome/#post-in-the-best-place

    Thanks!

    – Cais.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Warning: Invalid argument supplied for foreach()’ is closed to new replies.