Support » Plugin: RediSearch » Warning: Invalid argument supplied

  • James

    (@glidem)


    When enabling the plugin I get this message appearing in admin and on the frontend. Any help would be appreciated.

    Warning: Invalid argument supplied for foreach() in /var/www/vip13/sites/**********/httpd/htdocs/wp-content/plugins/redisearch/src/WpRediSearch.php on line 122

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author foadyousefi

    (@foadyousefi)

    Hi @glidem

    Sorry, a bit late answer. This line is where plugin checks if RediSearch module is installed on the server. To debug the issue, can you check which version of Redis and RediSearch module you are using, please?

    For this, if you have access to the server, run redis-server -v to find redis version and for RediSearch module, after entering redis-cli run MODULE LIST.

    Thread Starter James

    (@glidem)

    Hi @foadyousefi – no problem at all, thank you for the response.

    Redis version: 6.0.9
    Redisearch version: 2.0.10

    Plugin Author foadyousefi

    (@foadyousefi)

    Thanks @glidem

    I’m not able to reproduce.

    Can you please add var_dump($loaded_modules); before line 122 in WpRediSearch.php on your development site, then refresh your site and post the results here.

    This line will dump the result of MODULE LIST, but shows the results PHP code can see.

    Thread Starter James

    (@glidem)

    string(28) “ERR unknown command ‘MODULE'”
    Warning: Invalid argument supplied for foreach() in /var/www/vip13/sites/*********/httpd/htdocs/wp-content/plugins/redisearch/src/WpRediSearch.php on line 123

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.