Support » Fixing WordPress » Warning: ini_get_all() has been disabled for security reasons

  • Resolved itscoolbro

    (@itscoolbro)


    Hey guys,

    I was in my website dashboard and saw there is an update available for wordpress, I just clicked on update and process has started, I was away for like 20 mins and once i came back, the last message on update page was “Disabling Maintenance mode…” I just waited another 20 mins but nothings changed. So i decided to reload the page but guess what, Now i can’t access WP-Admin and my website has an error on top of header:

    Warning: ini_get_all() has been disabled for security reasons in /home/itscoolb/public_html/wp-includes/load.php on line 1020

    How can i fix it guys? I can only access my website files via FTP and cpanel, Thank you

Viewing 15 replies - 1 through 15 (of 97 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Ahh. Yeah, that’s something of a problem.

    A call to ini_get_all() was added to WordPress 4.6. There’s really no option not to call it.

    Here’s the thing though, that’s a Warning message. Warnings can be ignored, so all you have to do is to check your wp-config.php file and see if WP_DEBUG is set to true. If it is, then set it to false instead.

    Alternatively, you need to ask your host how to disable the display_errors setting. What hosting service do you use?

    Additionally, you may want to tell them that ini_get_all is a safe call and should not be disabled.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Whoops, thanks for catching that Otto!

    Thanks guys!

    @james, Thank you very much but it didn’t work

    @samuel, Thanks man, I checked wp-config.php and WP_DEBUG is set to false. I was curios to be honest and change False to True and it added 2 extra warning to index page XD however changing back to False wiped out the 2 extra warnings. I’m using a local host provider tho, but it’s a really good one. I will definitely contact them right now and will keep you updated.

    Thanks again

    Same issue here. Did just the update and got the same error message.

    My WP_DEBUG is set to false. And changing it to true and back to flase again does not fix the issues.
    Just sent a mail to my host provider whether they can help.

    And just from experience…. as I got the problem (I’m bit of IT literate, but not related to WP), I think quite a few more people will have the same problem but will be stuck.

    I also have this problem too !
    after updating WordPress, the same error has been displayed
    and editing WP_DEBUG does not work

    right now i reported the problem to my hosting provider to see if they can do any work or not !

    Same here! Still struggling with it.

    Please share how your host providers dealt with it

    @why_o_why, I didn’t get it fixed by changing False to True too, i just said it wiped out the errors I’ve gotten from changing False to True. Sorry i think i confused you lol

    I hope we can solve this problem, I was just working on plugins and suddenly decided to update my wordpress, big mistake!

    ___
    Host is telling me to restore my website from a backup!! LOL, If i restore my websile, It will definitely work again but i will be unable to update my wordpress atll, cuz he same thing will happen.

    unfortunately my host provider told me to restore a backup too !

    Yeah I got the same problem so WP updates need to fix this one so it does not do it !!!
    I tried on three sites and got the same problem so its definately a problem beeing caused entirely by the update…

    You can do a fix by re installing the previous WP version 4.5 by FTP and overwriting the entire WP update. fixed all my sites immediately.

    So…Moral of this story !!! wait till everyone else has updated WP before your do !!!

    Looks like this happens if ini_get_all is in the disable_functions list.

    Might want to create an info.php file with the following:

    <?php
    phpinfo();
    ?>

    Then execute that and check the disable_functions value. See if your webhost will change this or allow you to use a custom PHP.INI which does not list it.

    I had the same problem.

    Vaultpress would not do an automated roll back so I downloaded the previous version of WordPress and FTP to my host. Then I replaced any missing files from a manual Vaultpress backup.

    All is now good and I too will wait for a fix before trying again.

    Agree with @termspec that should have let others discover this problem but if we all did that then we wouldn’t be able to issue this caution to others!

    This needs to fixed by WordPress if its happening to so many of us. we should not need to be asking our hosts for individual fixes, or modifying php ini files, this only amplifies the problem for future updates if we have all gone off at a tangent and done personal fixes that may not be compatible with future WP updates.

    Same issue here. Thanks @markrh for the clue. It is indeed in the disable_functions list on my host. I’ll talk to them tomorrow.

    With my limited knowledge, I think that people should not leave the info.php file present on their site for security reasons, but I may be out of date on this?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Okay, please post which web hosts you’re using. We can’t give you specific details on how to fix without that info.

    Not all hosts have this problem, so we need to make a list.

Viewing 15 replies - 1 through 15 (of 97 total)
  • The topic ‘Warning: ini_get_all() has been disabled for security reasons’ is closed to new replies.