Support » Plugin: Improve My City » Warning in Status Insert (1.3.2.1)

  • Resolved ayron

    (@ayron)


    After the last update, the following message appears when I will include a status item.
    This behavior did not appear in previous versions. Can you reproduce this? Thanks

    Warning: Parameter 1 to end() expected to be a reference, value given in ../wp-content/plugins/improve-my-city/functions/imc-core-taxstatus-ordering.php on line 297

    Warning: Cannot modify header information – headers already sent by (output started at ../wp-content/plugins/improve-my-city/functions/imc-core-taxstatus-ordering.php:297) in ../wp-includes/pluggable.php on line 1179

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Improve My City

    (@improvemycity)

    Hello,

    Maybe you forgot to switch off php warnings after development?

    Hi,
    The warning did not appear in previous versions of the plugin.
    But I did the following test. The warning messages appear in versions 7 and 7.1 of php, they do not appear when I use version 5.6. For performance and security reasons, I always use the latest version.

    I had changed the php version from 7.1 to 5.6 to see if the problem with the timeline could be associated with it. Unfortunately not.

    Thanks

    • This reply was modified 2 years, 7 months ago by  ayron.
    Plugin Author Improve My City

    (@improvemycity)

    Okay,

    We’ll look into this.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Warning in Status Insert (1.3.2.1)’ is closed to new replies.