Support » Plugin: Radio Buttons for Taxonomies » Warning in 1.4.2

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    What screen are you seeing that on? Is RBFT the only plugin you have active?

    Here is a screenshot. Was working fine in 1.3. Only occurs when Radio Buttons for Taxonomies is active.

    Also, is there a way to turn ‘no term’ off? I want a selection to be a requirement. ‘No term’ shouldn’t be an option.

    Plugin Author helgatheviking

    (@helgatheviking)

    Thanks for the screenshot, that helps.

    Figures you’d want to turn ‘no term’ off. I added it b/c someone else wanted it! 🙂 I’ll have to investigate adding a filter or plugin option.

    Plugin Author helgatheviking

    (@helgatheviking)

    Brian, in the short-term you can remove the “no term” option by removing the filter I am applying to get_terms.

    For example, to disable for a taxonomy called genre:

    function remove_no_term(){
      global $Radio_Buttons_for_Taxonomies;
      remove_filter('get_terms', array( $Radio_Buttons_for_Taxonomies->genre, 'get_terms' ) );
    }
    add_action( 'admin_init', 'remove_no_term' );

    I’ll try to add better filters in the future…

    Plugin Author helgatheviking

    (@helgatheviking)

    In the next release you will be able to do:

    add_filter('radio-buttons-for-taxonomies-no-term-genre', '__return_FALSE' );

    if you want to disable the “no term” option on the genre taxonomy.

    I’ve got another issue in github to deal with before i push out an update…. but hopefully this week.

    Plugin Author helgatheviking

    (@helgatheviking)

    Also, the upcoming update should resolve the PHP warning

    Cool. My sites are just remaining in 1.3 for now.

    Thanks for all the updates.

    Plugin Author helgatheviking

    (@helgatheviking)

    I pushed out an update with a couple of bug fixes earlier today, it should be in the repo now. 1.4.3. I would suggest trying it out on one site… preferably a demo/test area.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Warning in 1.4.2’ is closed to new replies.